summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-09-14 19:51:38 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-10-10 07:55:10 +0200
commit24312f3454ceb97ce7de0fa1c5ca2b1a220f2da2 (patch)
treef8750b685c2cf5bea919ccd46891f67ad1523d66 /cpukit/Makefile.am
parentbuild: Merge posix/Makefile.am (diff)
downloadrtems-24312f3454ceb97ce7de0fa1c5ca2b1a220f2da2.tar.bz2
build: Merge pppd/Makefile.am
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am25
1 files changed, 24 insertions, 1 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index e6b7ec0de5..957197c5dd 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -844,7 +844,6 @@ _SUBDIRS += wrapup
# other libraries
_SUBDIRS += zlib
_SUBDIRS += telnetd
-_SUBDIRS += pppd
project_lib_LIBRARIES += libftpd.a
@@ -923,6 +922,30 @@ libnfs_a_SOURCES += libfs/src/nfsclient/src/rpcio.c
libnfs_a_SOURCES += libfs/src/nfsclient/src/sock_mbuf.c
libnfs_a_SOURCES += libfs/src/nfsclient/src/xdr_mbuf.c
+project_lib_LIBRARIES += libpppd.a
+
+$(PROJECT_LIB)/libpppd.a: libpppd.a
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/libpppd.a
+TMPINSTALL_FILES += $(PROJECT_LIB)/libpppd.a
+
+libpppd_a_SOURCES =
+libpppd_a_SOURCES += pppd/auth.c
+libpppd_a_SOURCES += pppd/ccp.c
+libpppd_a_SOURCES += pppd/chap.c
+libpppd_a_SOURCES += pppd/chap_ms.c
+libpppd_a_SOURCES += pppd/chat.c
+libpppd_a_SOURCES += pppd/demand.c
+libpppd_a_SOURCES += pppd/fsm.c
+libpppd_a_SOURCES += pppd/ipcp.c
+libpppd_a_SOURCES += pppd/lcp.c
+libpppd_a_SOURCES += pppd/magic.c
+libpppd_a_SOURCES += pppd/options.c
+libpppd_a_SOURCES += pppd/rtemsmain.c
+libpppd_a_SOURCES += pppd/rtemspppd.c
+libpppd_a_SOURCES += pppd/sys-rtems.c
+libpppd_a_SOURCES += pppd/upap.c
+libpppd_a_SOURCES += pppd/utils.c
+
if HAS_PTHREADS
project_lib_LIBRARIES += libmghttpd.a