summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-09-14 20:02:02 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-10-10 07:55:12 +0200
commit1d93843a3a9b0b0538a3392d3d858d227b22dbd4 (patch)
tree069a39d7f79d3064737e4ac2ed883baf92e44a8c /cpukit/Makefile.am
parentbuild: Merge rtems/Makefile.am (diff)
downloadrtems-1d93843a3a9b0b0538a3392d3d858d227b22dbd4.tar.bz2
build: Merge score/Makefile.am
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am217
1 files changed, 217 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index af17507231..a8833f6e6b 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -629,6 +629,199 @@ libcpukit_a_SOURCES += rtems/src/timerserverfireafter.c
libcpukit_a_SOURCES += rtems/src/timerserverfirewhen.c
libcpukit_a_SOURCES += rtems/src/workspace.c
libcpukit_a_SOURCES += rtems/src/workspacegreedy.c
+libcpukit_a_SOURCES += score/src/allocatormutex.c
+libcpukit_a_SOURCES += score/src/apimutexisowner.c
+libcpukit_a_SOURCES += score/src/apimutexlock.c
+libcpukit_a_SOURCES += score/src/apimutexunlock.c
+libcpukit_a_SOURCES += score/src/corebarrier.c
+libcpukit_a_SOURCES += score/src/corebarrierrelease.c
+libcpukit_a_SOURCES += score/src/corebarrierwait.c
+libcpukit_a_SOURCES += score/src/coremsg.c
+libcpukit_a_SOURCES += score/src/coremsgbroadcast.c
+libcpukit_a_SOURCES += score/src/coremsgclose.c
+libcpukit_a_SOURCES += score/src/coremsgflush.c
+libcpukit_a_SOURCES += score/src/coremsgflushwait.c
+libcpukit_a_SOURCES += score/src/coremsginsert.c
+libcpukit_a_SOURCES += score/src/coremsgseize.c
+libcpukit_a_SOURCES += score/src/coremsgsubmit.c
+libcpukit_a_SOURCES += score/src/coremutexseize.c
+libcpukit_a_SOURCES += score/src/percpu.c
+libcpukit_a_SOURCES += score/src/percpuasm.c
+libcpukit_a_SOURCES += score/src/corerwlock.c
+libcpukit_a_SOURCES += score/src/corerwlockobtainread.c
+libcpukit_a_SOURCES += score/src/corerwlockobtainwrite.c
+libcpukit_a_SOURCES += score/src/corerwlockrelease.c
+libcpukit_a_SOURCES += score/src/coresem.c
+libcpukit_a_SOURCES += score/src/heap.c
+libcpukit_a_SOURCES += score/src/heapallocate.c
+libcpukit_a_SOURCES += score/src/heapextend.c
+libcpukit_a_SOURCES += score/src/heapfree.c
+libcpukit_a_SOURCES += score/src/heapsizeofuserarea.c
+libcpukit_a_SOURCES += score/src/heapwalk.c
+libcpukit_a_SOURCES += score/src/heapgetinfo.c
+libcpukit_a_SOURCES += score/src/heapgetfreeinfo.c
+libcpukit_a_SOURCES += score/src/heapresizeblock.c
+libcpukit_a_SOURCES += score/src/heapiterate.c
+libcpukit_a_SOURCES += score/src/heapgreedy.c
+libcpukit_a_SOURCES += score/src/heapnoextend.c
+libcpukit_a_SOURCES += score/src/objectallocate.c
+libcpukit_a_SOURCES += score/src/objectclose.c
+libcpukit_a_SOURCES += score/src/objectextendinformation.c
+libcpukit_a_SOURCES += score/src/objectfree.c
+libcpukit_a_SOURCES += score/src/objectgetnext.c
+libcpukit_a_SOURCES += score/src/objectinitializeinformation.c
+libcpukit_a_SOURCES += score/src/objectnametoid.c
+libcpukit_a_SOURCES += score/src/objectnametoidstring.c
+libcpukit_a_SOURCES += score/src/objectshrinkinformation.c
+libcpukit_a_SOURCES += score/src/objectgetnoprotection.c
+libcpukit_a_SOURCES += score/src/objectidtoname.c
+libcpukit_a_SOURCES += score/src/objectgetnameasstring.c
+libcpukit_a_SOURCES += score/src/objectsetname.c
+libcpukit_a_SOURCES += score/src/objectgetinfo.c
+libcpukit_a_SOURCES += score/src/objectgetinfoid.c
+libcpukit_a_SOURCES += score/src/objectapimaximumclass.c
+libcpukit_a_SOURCES += score/src/objectnamespaceremove.c
+libcpukit_a_SOURCES += score/src/objectactivecount.c
+libcpukit_a_SOURCES += score/src/objectgetlocal.c
+libcpukit_a_SOURCES += score/src/log2table.c
+libcpukit_a_SOURCES += score/src/scheduler.c
+libcpukit_a_SOURCES += score/src/schedulergetaffinity.c
+libcpukit_a_SOURCES += score/src/schedulersetaffinity.c
+libcpukit_a_SOURCES += score/src/schedulerdefaultmappriority.c
+libcpukit_a_SOURCES += score/src/schedulerdefaultnodedestroy.c
+libcpukit_a_SOURCES += score/src/schedulerdefaultnodeinit.c
+libcpukit_a_SOURCES += score/src/schedulerdefaultreleasejob.c
+libcpukit_a_SOURCES += score/src/schedulerdefaultschedule.c
+libcpukit_a_SOURCES += score/src/schedulerdefaultstartidle.c
+libcpukit_a_SOURCES += score/src/schedulerdefaulttick.c
+libcpukit_a_SOURCES += score/src/schedulerpriority.c
+libcpukit_a_SOURCES += score/src/schedulerpriorityblock.c
+libcpukit_a_SOURCES += score/src/schedulerprioritychangepriority.c
+libcpukit_a_SOURCES += score/src/schedulerpriorityschedule.c
+libcpukit_a_SOURCES += score/src/schedulerpriorityunblock.c
+libcpukit_a_SOURCES += score/src/schedulerpriorityyield.c
+libcpukit_a_SOURCES += score/src/schedulersimple.c
+libcpukit_a_SOURCES += score/src/schedulersimpleblock.c
+libcpukit_a_SOURCES += score/src/schedulersimplechangepriority.c
+libcpukit_a_SOURCES += score/src/schedulersimpleschedule.c
+libcpukit_a_SOURCES += score/src/schedulersimpleunblock.c
+libcpukit_a_SOURCES += score/src/schedulersimpleyield.c
+libcpukit_a_SOURCES += score/src/scheduleredf.c
+libcpukit_a_SOURCES += score/src/scheduleredfnodeinit.c
+libcpukit_a_SOURCES += score/src/scheduleredfblock.c
+libcpukit_a_SOURCES += score/src/scheduleredfchangepriority.c
+libcpukit_a_SOURCES += score/src/scheduleredfreleasejob.c
+libcpukit_a_SOURCES += score/src/scheduleredfschedule.c
+libcpukit_a_SOURCES += score/src/scheduleredfunblock.c
+libcpukit_a_SOURCES += score/src/scheduleredfyield.c
+libcpukit_a_SOURCES += score/src/schedulercbs.c
+libcpukit_a_SOURCES += score/src/schedulercbsnodeinit.c
+libcpukit_a_SOURCES += score/src/schedulercbsattachthread.c
+libcpukit_a_SOURCES += score/src/schedulercbscleanup.c
+libcpukit_a_SOURCES += score/src/schedulercbscreateserver.c
+libcpukit_a_SOURCES += score/src/schedulercbsdestroyserver.c
+libcpukit_a_SOURCES += score/src/schedulercbsdetachthread.c
+libcpukit_a_SOURCES += score/src/schedulercbsgetapprovedbudget.c
+libcpukit_a_SOURCES += score/src/schedulercbsgetexecutiontime.c
+libcpukit_a_SOURCES += score/src/schedulercbsgetparameters.c
+libcpukit_a_SOURCES += score/src/schedulercbsgetremainingbudget.c
+libcpukit_a_SOURCES += score/src/schedulercbsgetserverid.c
+libcpukit_a_SOURCES += score/src/schedulercbssetparameters.c
+libcpukit_a_SOURCES += score/src/schedulercbsreleasejob.c
+libcpukit_a_SOURCES += score/src/schedulercbsunblock.c
+libcpukit_a_SOURCES += score/src/pheapallocate.c
+libcpukit_a_SOURCES += score/src/pheapextend.c
+libcpukit_a_SOURCES += score/src/pheapfree.c
+libcpukit_a_SOURCES += score/src/pheapgetsize.c
+libcpukit_a_SOURCES += score/src/pheapgetblocksize.c
+libcpukit_a_SOURCES += score/src/pheapgetfreeinfo.c
+libcpukit_a_SOURCES += score/src/pheapgetinfo.c
+libcpukit_a_SOURCES += score/src/pheapinit.c
+libcpukit_a_SOURCES += score/src/pheapresizeblock.c
+libcpukit_a_SOURCES += score/src/pheapwalk.c
+libcpukit_a_SOURCES += score/src/pheapiterate.c
+libcpukit_a_SOURCES += score/src/freechain.c
+libcpukit_a_SOURCES += score/src/rbtreeextract.c
+libcpukit_a_SOURCES += score/src/rbtreeinsert.c
+libcpukit_a_SOURCES += score/src/rbtreeiterate.c
+libcpukit_a_SOURCES += score/src/rbtreenext.c
+libcpukit_a_SOURCES += score/src/rbtreepostorder.c
+libcpukit_a_SOURCES += score/src/rbtreereplace.c
+libcpukit_a_SOURCES += score/src/thread.c
+libcpukit_a_SOURCES += score/src/threadchangepriority.c
+libcpukit_a_SOURCES += score/src/threadclearstate.c
+libcpukit_a_SOURCES += score/src/threadcreateidle.c
+libcpukit_a_SOURCES += score/src/threaddispatch.c
+libcpukit_a_SOURCES += score/src/threadget.c
+libcpukit_a_SOURCES += score/src/threadhandler.c
+libcpukit_a_SOURCES += score/src/threadinitialize.c
+libcpukit_a_SOURCES += score/src/threadloadenv.c
+libcpukit_a_SOURCES += score/src/threadrestart.c
+libcpukit_a_SOURCES += score/src/threadsetstate.c
+libcpukit_a_SOURCES += score/src/threadstackallocate.c
+libcpukit_a_SOURCES += score/src/threadstackfree.c
+libcpukit_a_SOURCES += score/src/threadstart.c
+libcpukit_a_SOURCES += score/src/threadstartmultitasking.c
+libcpukit_a_SOURCES += score/src/iterateoverthreads.c
+libcpukit_a_SOURCES += score/src/threadentryadaptoridle.c
+libcpukit_a_SOURCES += score/src/threadentryadaptornumeric.c
+libcpukit_a_SOURCES += score/src/threadentryadaptorpointer.c
+libcpukit_a_SOURCES += score/src/threadgetcputimeused.c
+libcpukit_a_SOURCES += score/src/threaditerate.c
+libcpukit_a_SOURCES += score/src/threadname.c
+libcpukit_a_SOURCES += score/src/threadscheduler.c
+libcpukit_a_SOURCES += score/src/threadtimeout.c
+libcpukit_a_SOURCES += score/src/threadwaitgetid.c
+libcpukit_a_SOURCES += score/src/threadyield.c
+libcpukit_a_SOURCES += score/src/threadq.c
+libcpukit_a_SOURCES += score/src/threadqenqueue.c
+libcpukit_a_SOURCES += score/src/threadqextractwithproxy.c
+libcpukit_a_SOURCES += score/src/threadqfirst.c
+libcpukit_a_SOURCES += score/src/threadqflush.c
+libcpukit_a_SOURCES += score/src/threadqops.c
+libcpukit_a_SOURCES += score/src/threadqtimeout.c
+libcpukit_a_SOURCES += score/src/timespecaddto.c
+libcpukit_a_SOURCES += score/src/timespecfromticks.c
+libcpukit_a_SOURCES += score/src/timespecisvalid.c
+libcpukit_a_SOURCES += score/src/timespeclessthan.c
+libcpukit_a_SOURCES += score/src/timespecsubtract.c
+libcpukit_a_SOURCES += score/src/timespectoticks.c
+libcpukit_a_SOURCES += score/src/timespecdivide.c
+libcpukit_a_SOURCES += score/src/timespecdividebyinteger.c
+libcpukit_a_SOURCES += score/src/timespecgetasnanoseconds.c
+libcpukit_a_SOURCES += score/src/coretod.c
+libcpukit_a_SOURCES += score/src/coretodset.c
+libcpukit_a_SOURCES += score/src/coretodtickspersec.c
+libcpukit_a_SOURCES += score/src/coretodadjust.c
+libcpukit_a_SOURCES += score/src/watchdoginsert.c
+libcpukit_a_SOURCES += score/src/watchdogremove.c
+libcpukit_a_SOURCES += score/src/watchdogtick.c
+libcpukit_a_SOURCES += score/src/watchdogtickssinceboot.c
+libcpukit_a_SOURCES += score/src/userextaddset.c
+libcpukit_a_SOURCES += score/src/userext.c
+libcpukit_a_SOURCES += score/src/userextremoveset.c
+libcpukit_a_SOURCES += score/src/userextiterate.c
+libcpukit_a_SOURCES += score/src/chain.c
+libcpukit_a_SOURCES += score/src/chainnodecount.c
+libcpukit_a_SOURCES += score/src/debugisthreaddispatchingallowed.c
+libcpukit_a_SOURCES += score/src/interr.c
+libcpukit_a_SOURCES += score/src/isr.c
+libcpukit_a_SOURCES += score/src/wkspace.c
+libcpukit_a_SOURCES += score/src/wkstringduplicate.c
+libcpukit_a_SOURCES += score/src/ioprintf.c
+libcpukit_a_SOURCES += score/src/iovprintf.c
+libcpukit_a_SOURCES += score/src/isrisinprogress.c
+libcpukit_a_SOURCES += score/src/condition.c
+libcpukit_a_SOURCES += score/src/futex.c
+libcpukit_a_SOURCES += score/src/profilingisrentryexit.c
+libcpukit_a_SOURCES += score/src/mutex.c
+libcpukit_a_SOURCES += score/src/once.c
+libcpukit_a_SOURCES += score/src/sched.c
+libcpukit_a_SOURCES += score/src/semaphore.c
+libcpukit_a_SOURCES += score/src/smpbarrierwait.c
+libcpukit_a_SOURCES += score/src/kern_tc.c
+libcpukit_a_SOURCES += score/src/libatomic.c
+libcpukit_a_SOURCES += score/src/processormaskcopy.c
libcpukit_a_SOURCES += sapi/src/chainappendnotify.c
libcpukit_a_SOURCES += sapi/src/chaingetnotify.c
libcpukit_a_SOURCES += sapi/src/chaingetwait.c
@@ -676,6 +869,9 @@ libcpukit_a_SOURCES += rtems/src/partmp.c
libcpukit_a_SOURCES += rtems/src/semmp.c
libcpukit_a_SOURCES += rtems/src/signalmp.c
libcpukit_a_SOURCES += rtems/src/taskmp.c
+libcpukit_a_SOURCES += score/src/mpci.c
+libcpukit_a_SOURCES += score/src/objectmp.c
+libcpukit_a_SOURCES += score/src/threadmp.c
endif
@@ -790,6 +986,27 @@ libcpukit_a_SOURCES += posix/src/ualarm.c
endif
+if HAS_SMP
+
+libcpukit_a_SOURCES += score/src/percpustatewait.c
+libcpukit_a_SOURCES += score/src/profilingsmplock.c
+libcpukit_a_SOURCES += score/src/schedulerdefaultpinunpin.c
+libcpukit_a_SOURCES += score/src/scheduleredfsmp.c
+libcpukit_a_SOURCES += score/src/schedulerpriorityaffinitysmp.c
+libcpukit_a_SOURCES += score/src/schedulerprioritysmp.c
+libcpukit_a_SOURCES += score/src/schedulersimplesmp.c
+libcpukit_a_SOURCES += score/src/schedulerstrongapa.c
+libcpukit_a_SOURCES += score/src/smp.c
+libcpukit_a_SOURCES += score/src/smplock.c
+libcpukit_a_SOURCES += score/src/smpmulticastaction.c
+libcpukit_a_SOURCES += score/src/schedulerdefaultaskforhelp.c
+libcpukit_a_SOURCES += score/src/schedulerdefaultsetaffinity.c
+libcpukit_a_SOURCES += score/src/schedulersmp.c
+libcpukit_a_SOURCES += score/src/schedulersmpstartidle.c
+libcpukit_a_SOURCES += score/src/threadunpin.c
+
+endif
+
if LIBDL
libcpukit_a_SOURCES += libdl/dlfcn.c