summaryrefslogtreecommitdiffstats
path: root/contrib/repo-conf/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2008-11-19 03:31:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2008-11-19 03:31:05 +0000
commitc51adc7911dac02b4f24735bb9e8769efdb1d888 (patch)
treeb1f8009b009b7a25912a7771b6061526cf000acb /contrib/repo-conf/configure.ac
parentinclude/bsp.h, include/hwreg_vals.h, network/network.c: (diff)
downloadrtems-c51adc7911dac02b4f24735bb9e8769efdb1d888.tar.bz2
Update.
Diffstat (limited to 'contrib/repo-conf/configure.ac')
-rw-r--r--contrib/repo-conf/configure.ac47
1 files changed, 36 insertions, 11 deletions
diff --git a/contrib/repo-conf/configure.ac b/contrib/repo-conf/configure.ac
index eec0e47cd4..abe665b97e 100644
--- a/contrib/repo-conf/configure.ac
+++ b/contrib/repo-conf/configure.ac
@@ -2,27 +2,52 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.61)
-AC_INIT([rtems-]_RTEMS_API[-repo-conf],[0.12],[http://www.rtems.org/bugzilla],
+AC_INIT([rtems-]_RTEMS_API[-repo-conf],[0.14],[http://www.rtems.org/bugzilla],
[rtems-]_RTEMS_API[-repo-conf])
RTEMS_VERSIONING
+
AC_CONFIG_SRCDIR([gpg])
AC_CONFIG_AUX_DIR([.])
AC_SUBST([RTEMS_API],[_RTEMS_API])
AM_INIT_AUTOMAKE([dist-bzip2 no-dist-gzip 1.10])
-AC_ARG_ENABLE(os_subdir,AS_HELP_STRING(
-[--enable-os-subdir=<dir> ... os subdirectory]),
-[os_subdir="$enable_os_subdir"],
-[os_subdir="fedora/"])
-AC_SUBST([OS_SUBDIR],[$os_subdir])
+AC_ARG_ENABLE(osname,AS_HELP_STRING(
+[--enable-osname=<dir> ... os name]),
+[osname="$enable_osname"],
+[osname="fedora-10"])
-case "$os_subdir" in
-fedora/ ) os_name="Fedora";;
-redhat/el ) os_name="CentOS";;
-suse/ ) os_name="openSUSE";;
-*) AC_MSG_ERROR([Invalid os-name])
+case $osname in
+fedora-9* | fedora-10* )
+ os_name="Fedora"
+ os_subdir="fedora/"
+ yum_verdir="\$\$releasever"
+ apt_verdir="\$\$(VERSION)"
+ ;;
+centos-5* | redhat-el5* | fedora-7* | fedora-8* )
+ os_name="CentOS"
+ os_subdir="centos/"
+ yum_verdir="5"
+ apt_verdir="5"
+ ;;
+centos-4* | redhat-el4* | fedora-5* | fedora-6* )
+ os_name="CentOS"
+ os_subdir="centos/"
+ yum_verdir="4"
+ apt_verdir="4"
;;
+suse-*)
+ os_name="openSUSE"
+ os_subdir="suse/"
+ yum_verdir="\$\$releasever"
+ apt_verdir="\$\$(VERSION)"
+ ;;
+*)
+ AC_MSG_ERROR([Unsupported OS])
esac
+
+AC_SUBST([OS_SUBDIR],[$os_subdir])
+AC_SUBST([YUM_VERDIR],[$yum_verdir])
+AC_SUBST([APT_VERDIR],[$apt_verdir])
AC_SUBST([OS_NAME],[$os_name])
AC_CONFIG_FILES([Makefile])