summaryrefslogtreecommitdiffstats
path: root/contrib/crossrpms/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2006-02-19 05:06:06 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2006-02-19 05:06:06 +0000
commit0ce942a5d094d6161628a230a405ada19c11a012 (patch)
tree502f4af1d62df196035ad93a7064ed99d23fc01e /contrib/crossrpms/configure.ac
parentComment out @tool_target@-gcc %package (diff)
downloadrtems-0ce942a5d094d6161628a230a405ada19c11a012.tar.bz2
Add AC_CANONICAL_TARGET.
Apply target magic to setup rtems.
Diffstat (limited to 'contrib/crossrpms/configure.ac')
-rw-r--r--contrib/crossrpms/configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/contrib/crossrpms/configure.ac b/contrib/crossrpms/configure.ac
index 65b6684435..34386875e6 100644
--- a/contrib/crossrpms/configure.ac
+++ b/contrib/crossrpms/configure.ac
@@ -8,6 +8,8 @@ AC_CONFIG_SRCDIR([binutils/binutils.add])
AC_CONFIG_AUX_DIR(.)
AC_CANONICAL_HOST
+AC_CANONICAL_TARGET
+
AC_PREFIX_DEFAULT([/opt/rtems-][RTEMS_API])
AM_INIT_AUTOMAKE([no-define foreign 1.9])
@@ -40,7 +42,6 @@ AC_ARG_ENABLE([rpmprefix],
])
AC_SUBST(rpmprefix)
-
AS_IF([test "${host}" != "${build}"],[
AC_MSG_CHECKING(for RPM OS)
case "$host" in
@@ -57,6 +58,15 @@ AC_MSG_RESULT($RPM_OS)
])
AC_SUBST(RPM_OS)
+case "${target_os}" in
+ rtems|[rtems]RTEMS_API[])
+ TARGET_SUBDIRS=rtems
+ ;;
+ *)
+ AC_MSG_ERROR([Unsupported target ${target}])
+esac
+AC_SUBST([TARGET_SUBDIRS])
+
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([cygwin/Makefile])