summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1997-12-01 21:27:24 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1997-12-01 21:27:24 +0000
commitba1a2af91e47f3b31b5022437f978cda6ced8277 (patch)
treeb11d3afad79d808066aa74ef936845cc690f3c34 /configure.in
parentEven more cleanup to make sure all the --enable/disable options avoid (diff)
downloadrtems-ba1a2af91e47f3b31b5022437f978cda6ced8277.tar.bz2
Fixed test for RTEMS_HAS_POSIX_API so the executive POSIX API related
Makefiles would be properly generated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index d8ee497dea..905c4cee1f 100644
--- a/configure.in
+++ b/configure.in
@@ -17,26 +17,26 @@ AC_ARG_ENABLE(gmake-print-directory, \
esac],[RTEMS_USE_OWN_PDIR=yes])
AC_ARG_ENABLE(posix, \
-[ --disable-posix disable posix interface], \
+[ --enable-posix enable posix interface], \
[case "${enableval}" in
yes) RTEMS_HAS_POSIX_API=yes ;;
no) RTEMS_HAS_POSIX_API=no ;;
- *) AC_MSG_ERROR(bad value ${enableval} for disable-posix option) ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for enable-posix option) ;;
esac],[RTEMS_HAS_POSIX_API=yes])
AC_ARG_ENABLE(ka9q, \
-[ --disable-ka9q disable KA9Q TCP/IP stack], \
+[ --enable-ka9q enable KA9Q TCP/IP stack], \
[case "${enableval}" in
yes) RTEMS_HAS_KA9Q=yes ;;
no) RTEMS_HAS_KA9Q=no ;;
- *) AC_MSG_ERROR(bad value ${enableval} for disable-ka9q option) ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for enable-ka9q option) ;;
esac],[RTEMS_HAS_KA9Q=yes])
AC_ARG_ENABLE(rtems-inlines, \
-[ --disable-rtems-inlines disable RTEMS inline functions (use macros)], \
+[ --enable-rtems-inlines enable RTEMS inline functions (use macros)], \
[case "${enableval}" in
- yes) RTEMS_USE_MACROS=yes ;;
- no) RTEMS_USE_MACROS=no ;;
+ yes) RTEMS_USE_MACROS=no ;;
+ no) RTEMS_USE_MACROS=yes ;;
*) AC_MSG_ERROR(bad value ${enableval} for disable-rtems-inlines option) ;;
esac],[RTEMS_USE_MACROS=no])
@@ -171,9 +171,9 @@ fi
RTEMS_CHECK_MAKEFILE(c/src/exec/rtems)
RTEMS_CHECK_MAKEFILE(c/src/exec/sapi)
-if test "$RTEMS_HAS_POSIX" = "yes"; then
+if test "$RTEMS_HAS_POSIX_API" = "yes"; then
RTEMS_CHECK_MAKEFILE(c/src/exec/posix)
- makefiles="$makefiles c/src/exec/posix/Makefile"
+ makefiles="$makefiles c/src/exec/wrapup/posix/Makefile"
fi
# find all the Makefiles for the BSPs