summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1998-01-15 20:29:51 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1998-01-15 20:29:51 +0000
commit566aea7ddb153d7ac24343ae12d519dd349d7917 (patch)
tree6fa02a2f82f0a1fde55ca7be51aee429f17ff5b4 /configure.in
parentUpdates from Eric Norum. Changed CPU CFLAG and went to a common name (diff)
downloadrtems-566aea7ddb153d7ac24343ae12d519dd349d7917.tar.bz2
Fixed code for --disable-rtems-inlines so that it would complete
configuration successfully. Added code to detect configuring macros and POSIX API at the same time. There is no macro implementation for the POSIX API.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 95659f541b..abc05405e4 100644
--- a/configure.in
+++ b/configure.in
@@ -268,6 +268,17 @@ fi
RTEMS_ROOT=`cd $srcdir/c; pwd`
PROJECT_ROOT=`pwd;`
+# If RTEMS macros are enabled, then use them. Otherwise, use inlines.
+if test "$RTEMS_USE_MACROS" = "yes"; then
+ inline_dir=macros
+ if test "$RTEMS_HAS_POSIX_API" = "yes"; then
+ # The problem is that there is currently no code in posix/macros :)
+ AC_MSG_ERROR(Macros are not implemented for the POSIX API)
+ fi
+else
+ inline_dir=inline
+fi
+
# If the KA9Q TCP/IP stack is enabled, then find all KA9Q Makefiles
if test "$RTEMS_HAS_KA9Q" = "yes"; then
makefiles="$makefiles c/src/lib/libka9q/Makefile"
@@ -356,7 +367,7 @@ c/src/exec/Makefile
c/src/exec/score/Makefile
c/src/exec/score/cpu/Makefile
c/src/exec/score/headers/Makefile
-c/src/exec/score/inline/Makefile
+c/src/exec/score/${inline_dir}/Makefile
c/src/exec/score/src/Makefile
c/src/exec/score/tools/Makefile
c/src/exec/score/tools/generic/Makefile