summaryrefslogtreecommitdiffstats
path: root/c/src/tests/support/wrapup/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-23 14:16:15 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-23 14:16:15 +0000
commitf26a3ab5d0b0f9945d65f1a2710303957a55d4da (patch)
tree494a4639e237f6bc0e9e095c8c2d789688df1740 /c/src/tests/support/wrapup/Makefile.am
parentMissed in previous automake conversion patches from Ralf Corsepius (diff)
downloadrtems-f26a3ab5d0b0f9945d65f1a2710303957a55d4da.tar.bz2
Patch rtems-rc-19991117-15.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
to convert the tests/support directory from Makefile.in to Makefile.am.
Diffstat (limited to 'c/src/tests/support/wrapup/Makefile.am')
-rw-r--r--c/src/tests/support/wrapup/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/c/src/tests/support/wrapup/Makefile.am b/c/src/tests/support/wrapup/Makefile.am
new file mode 100644
index 0000000000..752951613f
--- /dev/null
+++ b/c/src/tests/support/wrapup/Makefile.am
@@ -0,0 +1,33 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+LIBNAME=libtest
+LIB = $(ARCH)/$(LIBNAME).a
+
+GENERIC_FILES = stubdr
+
+# bummer; have to use $foreach since % pattern subst rules only replace 1x
+OBJS = $(foreach piece, $(GENERIC_FILES), ../$(piece)/$(ARCH)/$(piece).rel)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+TMPINSTALL_FILES += \
+$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a
+
+$(LIB): ${OBJS}
+ $(make-library)
+
+$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a: $(LIB)
+ $(INSTALL_DATA) $< $@
+
+all: ${ARCH} $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../../automake/local.am