summaryrefslogtreecommitdiffstats
path: root/c/src/tests/sptests/sp30/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-16 22:13:29 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-16 22:13:29 +0000
commitde569fee9ff6ded0a71bd76d3cdefb82b5399419 (patch)
treea89f18654b4ee8c6bc5b245a3dbd790c6dc45abe /c/src/tests/sptests/sp30/Makefile.am
parent2001-01-16 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-de569fee9ff6ded0a71bd76d3cdefb82b5399419.tar.bz2
2001-01-16 Joel Sherrill <joel@OARcorp.com>
* Added tests for task-based timers. This included the new tests sp30 and sp31. * Makefile.am, configure.ac: Modified to reflect new tests and files. * sp09/screen14.c, sp09/sp09.scn: Modified to add error checks for task-based timer services. * sp30/.cvsignore, sp30/Makefile.am, sp30/init.c, sp30/resume.c, sp30/sp30.doc, sp30/sp30.scn, sp30/system.h, sp30/task1.c, sp31/.cvsignore, sp31/Makefile.am, sp31/delay.c, sp31/init.c, sp31/prtime.c, sp31/sp31.doc, sp31/sp31.scn, sp31/system.h, sp31/task1.c: New files.
Diffstat (limited to 'c/src/tests/sptests/sp30/Makefile.am')
-rw-r--r--c/src/tests/sptests/sp30/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/c/src/tests/sptests/sp30/Makefile.am b/c/src/tests/sptests/sp30/Makefile.am
new file mode 100644
index 0000000000..75b71900d1
--- /dev/null
+++ b/c/src/tests/sptests/sp30/Makefile.am
@@ -0,0 +1,36 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+TEST = sp30
+
+MANAGERS = all
+
+C_FILES = init.c resume.c task1.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+DOCTYPES = scn
+DOCS = $(DOCTYPES:%=$(TEST).%)
+
+SRCS = $(C_FILES) $(H_FILES)
+OBJS = $(C_O_FILES)
+
+PRINT_SRCS = $(DOCS)
+
+PGM = ${ARCH}/$(TEST).exe
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../../../automake/leaf.am
+include $(top_srcdir)/sptests.am
+
+${PGM}: $(OBJS) $(LINK_FILES)
+ $(make-exe)
+
+all-local: $(ARCH) $(TMPINSTALL_FILES)
+
+EXTRA_DIST = $(C_FILES) $(DOCS)
+
+include $(top_srcdir)/../../../../automake/local.am