summaryrefslogtreecommitdiffstats
path: root/c/src/tests/mptests/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-29 15:45:11 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-29 15:45:11 +0000
commit1d9a2fc5abb83a5f37b10c63da8ccaf6ce0bda47 (patch)
treef24128f067d856bcaa4930c6c2d949a80cad0e38 /c/src/tests/mptests/Makefile.am
parentMade sure POSIX would build with MP enabled. (diff)
downloadrtems-1d9a2fc5abb83a5f37b10c63da8ccaf6ce0bda47.tar.bz2
Patch rtems-rc-19991123-rc-0.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
which (among other things) converted the mptests to automake. SUB_DIRS was used instead of SUBDIRS in some Makefile.ins (apparently a leftover from moving the start* directories) Addtional major bugs: * psxtests/include was empty (incomplete psxtests changes). * bogus handling of *.scn in itrontests (screens/sptests vs. screens/itrontests installation dirs) In addition I have added a few more changes (I couldn't resist) * automake support for itrontests * OPERATION_COUNT support in tmitrontests/ * automake support for tmitrontests * automake suppport for mptests * Some (minor) corrections to several configure.in/Makefile.ams => c/src/tests/ is completly under automake control, now. => we could start to sort out the structural issues with c/src/tests (tests/support, stubdr, tools, get "make dist" working)
Diffstat (limited to 'c/src/tests/mptests/Makefile.am')
-rw-r--r--c/src/tests/mptests/Makefile.am15
1 files changed, 3 insertions, 12 deletions
diff --git a/c/src/tests/mptests/Makefile.am b/c/src/tests/mptests/Makefile.am
index 04211afe91..8143d1b540 100644
--- a/c/src/tests/mptests/Makefile.am
+++ b/c/src/tests/mptests/Makefile.am
@@ -5,19 +5,10 @@
AUTOMAKE_OPTIONS = foreign 1.4
ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
-project_bspdir=$(PROJECT_ROOT)/@RTEMS_BSP@
-
-PREINSTALLDIRS = \
- $(project_bspdir)/tests/screens/mptests \
- $(project_bspdir)/tests/screens/mptests/node1 \
- $(project_bspdir)/tests/screens/mptests/node2
-$(PREINSTALLDIRS):
- @$(mkinstalldirs) $@
-
-all-local: $(PREINSTALLDIRS)
-
-SUBDIRS = . mp01 mp02 mp03 mp04 mp05 mp06 mp07 mp08 mp09 mp10 mp11 mp12 mp13 \
+SUBDIRS = mp01 mp02 mp03 mp04 mp05 mp06 mp07 mp08 mp09 mp10 mp11 mp12 mp13 \
mp14
+EXTRA_DIST = mptests.am
+
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am