summaryrefslogtreecommitdiffstats
path: root/c/src/optman/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-12-11 18:20:02 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-12-11 18:20:02 +0000
commit20996955edf891a3bd4f297e29b756b2038661c4 (patch)
treeb951018743f8db8896f801835f87611c997f7c02 /c/src/optman/Makefile.am
parent2002-12-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-20996955edf891a3bd4f297e29b756b2038661c4.tar.bz2
2002-12-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Eliminate *_O_FILES. Don't create $ARCH in %.o: %.c rules.
Diffstat (limited to 'c/src/optman/Makefile.am')
-rw-r--r--c/src/optman/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/c/src/optman/Makefile.am b/c/src/optman/Makefile.am
index df38993204..0ab4c2ee73 100644
--- a/c/src/optman/Makefile.am
+++ b/c/src/optman/Makefile.am
@@ -8,27 +8,24 @@ include $(top_srcdir)/../../../automake/compile.am
include $(top_srcdir)/../../../automake/lib.am
sapi_C_FILES = sapi/no-ext.c sapi/no-io.c
-C_O_FILES = $(sapi_C_FILES:sapi/%.c=$(ARCH)/%.$(OBJEXT))
+OBJS = $(sapi_C_FILES:sapi/%.c=$(ARCH)/%.$(OBJEXT))
rtems_C_FILES = rtems/no-dpmem.c rtems/no-event.c rtems/no-msg.c rtems/no-mp.c \
rtems/no-part.c rtems/no-region.c \
rtems/no-rtmon.c rtems/no-sem.c rtems/no-signal.c rtems/no-timer.c
-C_O_FILES += $(rtems_C_FILES:rtems/%.c=${ARCH}/%.$(OBJEXT))
+OBJS += $(rtems_C_FILES:rtems/%.c=${ARCH}/%.$(OBJEXT))
PGMS = $(rtems_C_FILES:rtems/%.c=$(ARCH)/%$(LIB_VARIANT).rel)
PGMS += $(sapi_C_FILES:sapi/%.c=$(ARCH)/%$(LIB_VARIANT).rel)
${ARCH}/%.$(OBJEXT): sapi/%.c
- test -d $(ARCH) || mkdir $(ARCH)
${COMPILE} -o $@ -c $<
${ARCH}/%.$(OBJEXT): rtems/%.c
- test -d $(ARCH) || mkdir $(ARCH)
${COMPILE} -o $@ -c $<
# Make foo.rel from foo.o
${ARCH}/%$(LIB_VARIANT).rel: ${ARCH}/%.o
- test -d $(ARCH) || mkdir $(ARCH)
${make-rel}
bsplib_DATA = $(PGMS)
@@ -41,7 +38,7 @@ $(PROJECT_RELEASE)/lib/%$(LIB_VARIANT).rel: $(ARCH)/%$(LIB_VARIANT).rel
all-local: ${ARCH} $(PGMS) $(TMPINSTALL_FILES)
-.PRECIOUS: $(PGMS) $(C_O_FILES)
+.PRECIOUS: $(PGMS) $(OBJS)
EXTRA_DIST = $(rtems_C_FILES) $(sapi_C_FILES)