summaryrefslogtreecommitdiffstats
path: root/c/src/make/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-07-30 17:52:50 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-07-30 17:52:50 +0000
commit1896a650fc382d343844b56f4b79efe31562755e (patch)
tree922de4dd1237cfcf6c7be0a8050e1e964fceadad /c/src/make/configure.in
parentFixed typos. (diff)
downloadrtems-1896a650fc382d343844b56f4b79efe31562755e.tar.bz2
Patch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>:
The main topic is replacing the hard-coded values for HAS_MP and HAS_RDBG in custom/*.cfg with per-bsp configuration-time autoconf checks (This is the patch I had mentioned before earlier this week). CHANGES * HAS_MP removed from custom/*.cfg, replaced with configuration time autoconf check * HAS_RDBG removed from custom/*.cfg, replaced with configuration-time autoconf check * NEW: c/src/make/bsp.cfg.in, takes configuration-time checked per-bsp values (i.e. HAS_MP, HAS_RDBG), gets installed as $(prefix)/<bsp>/make/bsp.cfg * NEW: default.cfg includes bsp.cfg - this change is backward compatible. * IMPORT_SRC: apply VPATH instead for ts_386ex/i386ex subdirectory Makefile.ins * HACK: a bug in acpolish mis-handles addtions to makefile variables which are enclosed in gmake conditionals: c/src/lib/libbsp/m68k/ods68302/start302/Makefile.in * Apply inline_dir, HAS_MP and HAS_RDBG for avoiding configuration of unneeded subdirectories in various configure.in files. * Several minor changes in Makefile.ins and configure.ins, wrt. to the order of including *.cfg and defining Makefile variables APPLYING THE PATCH: patch -p1 < rtems-rc-19990709-4.diff ./autogen
Diffstat (limited to 'c/src/make/configure.in')
-rw-r--r--c/src/make/configure.in13
1 files changed, 3 insertions, 10 deletions
diff --git a/c/src/make/configure.in b/c/src/make/configure.in
index e89887480e..2382b6d0c2 100644
--- a/c/src/make/configure.in
+++ b/c/src/make/configure.in
@@ -26,7 +26,6 @@ RTEMS_ENABLE_CXX
RTEMS_ENABLE_GCC28
RTEMS_ENABLE_LIBCDIR
RTEMS_ENABLE_BARE
-dnl RTEMS_ENABLE_RTEMSBSP
RTEMS_ENV_RTEMSBSP
@@ -71,16 +70,9 @@ RTEMS_CANONICALIZE_TOOLS
dnl if this is an i386, does gas have good code16 support?
RTEMS_I386_GAS_CODE16
-dnl RTEMS_CHECK_BSPS(rtems_bsp)
-
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
-
-if test "$RTEMS_HAS_RDBG" = "yes"; then
- RTEMS_CHECK_RDBG
- RTEMS_HAS_RDBG="$rtems_cv_has_rdbg";
-fi
-
-dnl END configure.target.in
+RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
+RTEMS_CHECK_RDBG(RTEMS_BSP)
AC_SUBST(rtems_cv_prog_cc_cross)
AC_SUBST(RTEMS_HAS_CPLUSPLUS)
@@ -131,6 +123,7 @@ Makefile.inc
main.cfg
host.cfg
target.cfg
+bsp.cfg
Templates/Makefile
custom/Makefile
custom/default.cfg