summaryrefslogtreecommitdiffstats
path: root/c/src/make/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2019-07-17 22:19:04 +1000
committerChris Johns <chrisj@rtems.org>2019-07-19 17:50:05 +1000
commit270c5df5dbaf93c19e2f66a27f4bb73c7e625629 (patch)
tree50c493a2212276ab93948412f18feaf949f85cc2 /c/src/make/Makefile.am
parentscore/interr: Fix comments. (diff)
downloadrtems-270c5df5dbaf93c19e2f66a27f4bb73c7e625629.tar.bz2
Makefile.inc: Add support for staged builds.
- Allow the RTEMS_ROOT to be conditionally supplied. This can be a staging area before being moved to the final install prefix location. - Update the default.cfg to use RTEMS_ROOT and to not rely on the exec_prefix so it's paths can be staged. - Fix and add the needed configure subs. Closes #3768
Diffstat (limited to 'c/src/make/Makefile.am')
-rw-r--r--c/src/make/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/c/src/make/Makefile.am b/c/src/make/Makefile.am
index 44350e94fd..2c630d9a78 100644
--- a/c/src/make/Makefile.am
+++ b/c/src/make/Makefile.am
@@ -68,6 +68,8 @@ Makefile.inc: Makefile.inc.in Makefile
-e "s|[@]exec_prefix[@]|$(exec_prefix)|" \
-e "s|[@]pkgdatadir[@]|$(pkgdatadir)|" \
-e "s|[@]RTEMS_BSP[@]|$(RTEMS_BSP)|" \
+ -e "s|[@]RTEMS_CPU[@]|$(RTEMS_CPU)|" \
+ -e "s|[@]RTEMS_API[@]|$(RTEMS_API)|" \
-e "s|[@]CC[@]|$(CC)|" \
-e "s|[@]CXX[@]|$(CXX)|" \
-e "s|[@]AS[@]|$(AS)|" \
@@ -85,4 +87,3 @@ CLEANFILES += Makefile.inc
## use gcc-target-default.cfg only.
rtems_make_compilersdir = $(rtems_makedir)/compilers
dist_rtems_make_compilers_DATA = compilers/gcc-target-default.cfg
-