summaryrefslogtreecommitdiffstats
path: root/c/src/librtems++/configure.ac
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2016-08-10 13:28:50 +1000
committerChris Johns <chrisj@rtems.org>2016-08-11 17:24:06 +1000
commit03c1038edbe9b01a72d4775dcb6ffc1a03193a0c (patch)
treee82822781679566a6a824211492e8f8cd98f16b6 /c/src/librtems++/configure.ac
parentbuild-system: Always enable C++ if the compiler is present. (diff)
downloadrtems-03c1038edbe9b01a72d4775dcb6ffc1a03193a0c.tar.bz2
librtems++: Remove from RTEMS.
This is old and there are better design patterns for threading and C++. We recommend you use the new C++ standards based support. Closes #2777.
Diffstat (limited to 'c/src/librtems++/configure.ac')
-rw-r--r--c/src/librtems++/configure.ac35
1 files changed, 0 insertions, 35 deletions
diff --git a/c/src/librtems++/configure.ac b/c/src/librtems++/configure.ac
deleted file mode 100644
index 085bb6a1ad..0000000000
--- a/c/src/librtems++/configure.ac
+++ /dev/null
@@ -1,35 +0,0 @@
-## Process this file with autoconf to produce a configure script.
-##
-
-AC_PREREQ([2.69])
-AC_INIT([rtems-c-src-librtems++],[_RTEMS_VERSION],[https://devel.rtems.org/newticket],[rtems-c-src-librtems++])
-AC_CONFIG_SRCDIR([include/rtems++])
-RTEMS_TOP(../../..)
-
-RTEMS_CANONICAL_TARGET_CPU
-
-AM_INIT_AUTOMAKE([no-define foreign subdir-objects 1.12.2])
-AM_MAINTAINER_MODE
-
-RTEMS_ENABLE_CXX
-
-RTEMS_ENV_RTEMSBSP
-
-RTEMS_CHECK_CXX(RTEMS_BSP)
-## check for g++
-RTEMS_PROG_CXX_FOR_TARGET
-RTEMS_CANONICALIZE_TOOLS
-
-AM_CONDITIONAL(HAS_CXX,test "$HAS_CPLUSPLUS" = "yes")
-
-AC_LANG_PUSH(C++)
-AC_CHECK_HEADER([cstring],[],[AC_MSG_ERROR([Required header cstring not found])])
-AC_CHECK_HEADER([cstdlib],[],[AC_MSG_ERROR([Required header cstdlib not found])])
-AC_LANG_POP
-
-RTEMS_PROJECT_ROOT
-RTEMS_AMPOLISH3
-
-# Explicitly list all Makefiles here
-AC_CONFIG_FILES([Makefile])
-AC_OUTPUT