summaryrefslogtreecommitdiffstats
path: root/c/src/librtems++/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-12-10 01:44:08 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-12-10 01:44:08 +0000
commit4735923113200518cce718609f49ebe5181b6d15 (patch)
treeed8973816b84bae8918dbf560e862f4755302429 /c/src/librtems++/Makefile.am
parent2002-12-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4735923113200518cce718609f49ebe5181b6d15.tar.bz2
2002-12-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* src/Makefile.am: Remove. * include/Makefile.am: Remove. * Makefile.am: Merge-in src/Makefile.am, include/Makefile.am. * configure.ac: Reflect changes above. Unconditionally check for CXX.
Diffstat (limited to 'c/src/librtems++/Makefile.am')
-rw-r--r--c/src/librtems++/Makefile.am48
1 files changed, 46 insertions, 2 deletions
diff --git a/c/src/librtems++/Makefile.am b/c/src/librtems++/Makefile.am
index 4fbb395f69..527e22c52f 100644
--- a/c/src/librtems++/Makefile.am
+++ b/c/src/librtems++/Makefile.am
@@ -4,7 +4,51 @@
ACLOCAL_AMFLAGS = -I ../../../aclocal
-SUBDIRS = include src
+include $(top_srcdir)/../../../automake/compile.am
+include $(top_srcdir)/../../../automake/lib.am
+
+include_rtems__dir = $(includedir)/rtems++
+
+$(PROJECT_INCLUDE)/%.h: include/%.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/rtems++:
+ @$(mkinstalldirs) $@
+
+if HAS_CXX
+include_rtems___HEADERS = include/rtems++/rtemsEvent.h \
+ include/rtems++/rtemsInterrupt.h include/rtems++/rtemsMessageQueue.h include/rtems++/rtemsSemaphore.h \
+ include/rtems++/rtemsStatusCode.h include/rtems++/rtemsTask.h include/rtems++/rtemsTaskMode.h \
+ include/rtems++/rtemsTimer.h
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems++ \
+ $(include_rtems___HEADERS:include/%=$(PROJECT_INCLUDE)/%)
+
+endif
+
+LIB = ${ARCH}/librtems++.a
+
+CC_FILES = src/rtemsEvent.cc src/rtemsInterrupt.cc src/rtemsMessageQueue.cc \
+ src/rtemsSemaphore.cc src/rtemsStatusCode.cc src/rtemsTask.cc src/rtemsTimer.cc
+CC_O_FILES = $(CC_FILES:src/%.cc=${ARCH}/%.$(OBJEXT))
+
+SRCS = $(CC_FILES)
+OBJS = $(CC_O_FILES)
+
+TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/librtems++$(LIB_VARIANT).a
+
+bsplib_DATA = $(LIB)
+
+${ARCH}/%.o: src/%.cc
+ test -d $(ARCH) || mkdir $(ARCH)
+ ${CXXCOMPILE} -o $@ -c $<
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+$(PROJECT_RELEASE)/lib/librtems++$(LIB_VARIANT).a: $(LIB)
+ $(INSTALL_DATA) $< $@
+
+all-local: ${ARCH} $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
-include $(top_srcdir)/../../../automake/subdirs.am
include $(top_srcdir)/../../../automake/local.am