summaryrefslogtreecommitdiffstats
path: root/c/src/librtems++/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-15 03:31:26 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-15 03:31:26 +0000
commit2dbcee87f2f1656731abadbbba426c482da22e69 (patch)
tree7a7b673ccb7f4b824d41c28a5a0a7c843d20ed40 /c/src/librtems++/Makefile.am
parent2004-01-14 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-2dbcee87f2f1656731abadbbba426c482da22e69.tar.bz2
2004-01-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Add subdir-objects to AUTOMAKE_OPTIONS * Makefile.am: Use automake-compilation rules.
Diffstat (limited to 'c/src/librtems++/Makefile.am')
-rw-r--r--c/src/librtems++/Makefile.am26
1 files changed, 15 insertions, 11 deletions
diff --git a/c/src/librtems++/Makefile.am b/c/src/librtems++/Makefile.am
index 2d2275437d..6b128371fa 100644
--- a/c/src/librtems++/Makefile.am
+++ b/c/src/librtems++/Makefile.am
@@ -7,8 +7,8 @@ ACLOCAL_AMFLAGS = -I ../aclocal
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/lib.am
-${ARCH}/%.o: src/%.cc $(ARCH)/$(dirstamp)
- ${CXXCOMPILE} -o $@ -c $<
+EXTRA_LIBRARIES =
+CLEANFILES =
if HAS_CXX
include_rtems__dir = $(includedir)/rtems++
@@ -19,15 +19,19 @@ include_rtems___HEADERS = include/rtems++/rtemsEvent.h \
include/rtems++/rtemsTask.h include/rtems++/rtemsTaskMode.h \
include/rtems++/rtemsTimer.h
-CC_FILES = src/rtemsEvent.cc src/rtemsInterrupt.cc src/rtemsMessageQueue.cc \
- src/rtemsSemaphore.cc src/rtemsStatusCode.cc src/rtemsTask.cc \
- src/rtemsTimer.cc
-OBJS = $(CC_FILES:src/%.cc=${ARCH}/%.$(OBJEXT))
+EXTRA_LIBRARIES += librtems++.a
+CLEANFILES += librtems++.a
+librtems___a_SOURCES = src/rtemsEvent.cc src/rtemsInterrupt.cc \
+ src/rtemsMessageQueue.cc src/rtemsSemaphore.cc src/rtemsStatusCode.cc \
+ src/rtemsTask.cc src/rtemsTimer.cc
+librtems___a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
-$(ARCH)/librtems++$(LIB_VARIANT).a: $(OBJS)
- $(make-library)
+EXTRA_LIBRARIES += librtems++_g.a
+CLEANFILES += librtems++_g.a
+librtems___g_a_SOURCES = $(librtems___a_SOURCES)
+librtems___g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-project_lib_DATA = $(ARCH)/librtems++$(LIB_VARIANT).a
+project_lib_DATA = librtems++$(LIB_VARIANT).a
endif
all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
@@ -78,12 +82,12 @@ $(PROJECT_INCLUDE)/rtems++/rtemsTimer.h: include/rtems++/rtemsTimer.h $(PROJECT_
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems++/rtemsTimer.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems++/rtemsTimer.h
-$(PROJECT_LIB)/librtems++$(LIB_VARIANT).a: $(ARCH)/librtems++$(LIB_VARIANT).a $(PROJECT_LIB)/$(dirstamp)
+$(PROJECT_LIB)/librtems++$(LIB_VARIANT).a: librtems++$(LIB_VARIANT).a $(PROJECT_LIB)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_LIB)/librtems++$(LIB_VARIANT).a
TMPINSTALL_FILES += $(PROJECT_LIB)/librtems++$(LIB_VARIANT).a
endif
-CLEANFILES = $(PREINSTALL_FILES)
+CLEANFILES += $(PREINSTALL_FILES)
CLEANFILES += $(TMPINSTALL_FILES)
include $(top_srcdir)/../automake/local.am