summaryrefslogtreecommitdiffstats
path: root/c/src/librdbg/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-13 21:07:22 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-13 21:07:22 +0000
commit4c3ab8463610365de864b0f769d210ee914a71ec (patch)
tree3888952129deab34466f212e5293446a19b5763a /c/src/librdbg/configure.in
parentAll m68k BSPs now build with new ELF style linkcmds. (diff)
downloadrtems-4c3ab8463610365de864b0f769d210ee914a71ec.tar.bz2
Patch rtems-rc-20000104-17.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that addresses the librdbg/rpcgen related problems: Changes: * All rpcgen generated files are now kept inside of the source tree * Fix librdbg/configure to correctly detect presence of rpcgen and awk * Use rpcgen -m to generated remdeb_svc.c * Remove msgout/_msgout from awk.svc * minor cleanups to librdbg/configure.in ATTENTION --- IMPORTANT: * With keeping rpc-generated files pre-build inside of the source tree, you as the packager of RTEMS have to ensure that timestamps are correctly set up: The generated files must not be older than the *.x files. * This is extraordinarily important when - putting the package on read-only media - after checking out from CVS - after modifications to the *.x files * If one of the *.x files is modified you have to either - build for i386/pc386 and powerpc/mcp750 - or to invoke the same rpcgen calls as the librdbg/src/<cpu>/<bsp>/Makefile.am do manually before checking-in the files to CVS. Proposal: We could add something to bootstrap for touching the rpcgen-generated sources and/or to manually regenerate them. NOTE FROM JOEL: Ralf proposed modifying bootstrap to handle rpcgen. I think this is the best solution as it is something already done in the snapshot procedure.
Diffstat (limited to 'c/src/librdbg/configure.in')
-rw-r--r--c/src/librdbg/configure.in15
1 files changed, 7 insertions, 8 deletions
diff --git a/c/src/librdbg/configure.in b/c/src/librdbg/configure.in
index c635e2604e..8711f6ba59 100644
--- a/c/src/librdbg/configure.in
+++ b/c/src/librdbg/configure.in
@@ -22,22 +22,24 @@ RTEMS_ENV_RTEMSBSP
RTEMS_CHECK_CPU
RTEMS_CANONICAL_HOST
-RTEMS_PROJECT_ROOT
-
dnl check target cc
RTEMS_PROG_CC_FOR_TARGET
RTEMS_CANONICALIZE_TOOLS
-AC_CHECK_PROG(RPCGEN,rpcgen,rpcgen)
+AC_CHECK_PROG(RPCGEN,rpcgen,rpcgen,no)
AC_PROG_AWK
if test "$RPCGEN" = "no"; then
- AC_MSG_ERROR([missing rpcgen, required to build librdbg])
+ AC_MSG_WARN([** missing rpcgen, required to build librdbg **])
+ rpctools="no"
fi
if test "$AWK" = "no"; then
- AC_MSG_ERROR([missing awk, required to build librdbg])
+ AC_MSG_WARN([** missing awk, required to build librdbg **])
+ rpctools="no"
fi
+AM_CONDITIONAL(RPCTOOLS, test "$rpctools" != "no")
+
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
RTEMS_BSP_ALIAS(${RTEMS_BSP},bspdir)
RTEMS_CHECK_NETWORKING(RTEMS_BSP)
@@ -45,9 +47,6 @@ RTEMS_CHECK_RDBG(bspdir)
AM_CONDITIONAL(HAS_RDBG,test "$HAS_RDBG" = "yes")
-PROJECT_INCLUDE="\$(PROJECT_ROOT)/$RTEMS_BSP/lib/include"
-AC_SUBST(PROJECT_INCLUDE)
-
RTEMS_PROJECT_ROOT
# Try to explicitly list a Makefile here