summaryrefslogtreecommitdiffstats
path: root/c/src/libnetworking/rtems/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-05-29 17:00:30 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-05-29 17:00:30 +0000
commit7020377e8f2214d2adbda252c52ecd54e15d7e97 (patch)
tree0d1aff815863220cb9ad20f070a110f0c17aeedd /c/src/libnetworking/rtems/Makefile.am
parent2001-05-29 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-7020377e8f2214d2adbda252c52ecd54e15d7e97.tar.bz2
2002-05-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
Move networking libraries to c/src/exec/libnetworking * configure.ac: Reflect Moval. * Makefile.am: Reflect Moval. * wrapup/Makefile.am: Reflect Moval.
Diffstat (limited to 'c/src/libnetworking/rtems/Makefile.am')
-rw-r--r--c/src/libnetworking/rtems/Makefile.am53
1 files changed, 0 insertions, 53 deletions
diff --git a/c/src/libnetworking/rtems/Makefile.am b/c/src/libnetworking/rtems/Makefile.am
deleted file mode 100644
index 131d5bd14f..0000000000
--- a/c/src/libnetworking/rtems/Makefile.am
+++ /dev/null
@@ -1,53 +0,0 @@
-##
-## $Id$
-##
-
-include_rtemsdir = $(includedir)/rtems
-
-LIBNAME = lib.a
-LIB = $(ARCH)/$(LIBNAME)
-
-C_FILES = sghostname.c issetugid.c rtems_glue.c rtems_syscall.c \
- rtems_bootp.c rtems_showmbuf.c rtems_showroute.c rtems_showifstat.c \
- rtems_showipstat.c rtems_showicmpstat.c rtems_showtcpstat.c \
- rtems_showudpstat.c rtems_select.c mkrootfs.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-
-OBJS = $(C_O_FILES)
-
-include_rtems_HEADERS = rtems_bsdnet.h rtems_bsdnet_internal.h tftp.h \
- mkrootfs.h
-
-PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems \
- $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
-
-$(PROJECT_INCLUDE)/rtems:
- @$(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/rtems/%.h: %.h
- $(INSTALL_DATA) $< $@
-
-include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
-
-#
-# Add local stuff here using +=
-#
-
-AM_CPPFLAGS += -D_COMPILING_BSD_KERNEL_ -DKERNEL -DINET -DNFS -DDIAGNOSTIC \
- -DBOOTP_COMPAT
-
-$(LIB): $(OBJS)
- $(make-library)
-
-all-local: $(PREINSTALL_FILES) $(ARCH) $(OBJS) $(LIB)
-
-.PRECIOUS: $(LIB)
-
-EXTRA_DIST = issetugid.c rtems_bootp.c rtems_glue.c rtems_select.c \
- rtems_showicmpstat.c rtems_showifstat.c rtems_showipstat.c \
- rtems_showmbuf.c rtems_showroute.c rtems_showtcpstat.c \
- rtems_showudpstat.c rtems_syscall.c sghostname.c
-
-include $(top_srcdir)/../../../automake/local.am