summaryrefslogtreecommitdiffstats
path: root/c/src/libnetworking/modem/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-25 22:10:01 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-25 22:10:01 +0000
commit85a0f07fb860e23174abaea0feb7076ae1012d63 (patch)
treeedf9672231ce84f7cb3e9d1574e73547888bafa7 /c/src/libnetworking/modem/Makefile.am
parent2000-11-25 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-85a0f07fb860e23174abaea0feb7076ae1012d63.tar.bz2
2000-11-25 Antti P Miettinen <antti.p.miettinen@nokia.com>
* wrapup/Makefile.am: Added modem subdir. * configure.in, Makefile.am: Added modem subdir. * net/Makefile.am: Added if_pppvar.h, pppcompress.h. * pppd/Makefile.am: Added pppmain.c (which needs work). * pppd/chat.c, pppd/fsm.c, pppd/fsm.h, pppd/ipxcp.c, pppd/main.c, pppd/ppp_tty.c, pppd/upap.c: Changes from Thomas Doerfler <Thomas.Doerfler@imd-systems.de> and cosmetic changes by me. Actually main.c and ppp_tty.c should be scratched. The modem subdir has the real ppp_tty.c and the real pppd main is in pppmain.c.
Diffstat (limited to 'c/src/libnetworking/modem/Makefile.am')
-rw-r--r--c/src/libnetworking/modem/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/c/src/libnetworking/modem/Makefile.am b/c/src/libnetworking/modem/Makefile.am
new file mode 100644
index 0000000000..86560501b4
--- /dev/null
+++ b/c/src/libnetworking/modem/Makefile.am
@@ -0,0 +1,39 @@
+##
+## $Id $
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+LIBNAME = lib.a
+LIB = $(ARCH)/$(LIBNAME)
+
+C_FILES = ppp_tty.c ppp.c pppcompress.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/compile.am
+include $(top_srcdir)/../../../automake/lib.am
+
+#
+# Add local stuff here using +=
+#
+
+# DEFINES += -D_COMPILING_BSD_KERNEL_ -DKERNEL -DINET -DNFS -DDIAGNOSTIC \
+# -DBOOTP_COMPAT
+
+AM_CPPFLAGS += -D__INSIDE_RTEMS_BSD_TCPIP_STACK__ \
+-D_COMPILING_BSD_KERNEL_ -DKERNEL -DINET -DNFS -DDIAGNOSTIC \
+-DBOOTP_COMPAT
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+all-local: $(ARCH) $(OBJS) $(LIB)
+
+.PRECIOUS: $(LIB)
+
+EXTRA_DIST = ppp_tty.c ppp.c ppp.h pppcompress.c
+
+include $(top_srcdir)/../../../automake/local.am