summaryrefslogtreecommitdiffstats
path: root/c/src/libnetworking/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:36:27 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:36:27 +0000
commite6d8fe4717c301925408786aee585fb96912e445 (patch)
tree18a65119b8150bfc661d3fee629eb8361d4e7555 /c/src/libnetworking/include/Makefile.am
parent2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-e6d8fe4717c301925408786aee585fb96912e445.tar.bz2
2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am, arpa/Makefile.am, machine/Makefile.am, net/Makefile.am, netinet/Makefile.am, nfs/Makefile.am, rtems/Makefile.am, rtems_servers/Makefile.am, rtems_webserver/Makefile.am, sys/Makefile.am, vm/Makefile.am: Apply include_*HEADERS instead of H_FILES. * include/Makefile.am: Remove. * Makefile.am: Add handling of *.h files. * configure.in: Remove include/Makefile.
Diffstat (limited to 'c/src/libnetworking/include/Makefile.am')
-rw-r--r--c/src/libnetworking/include/Makefile.am57
1 files changed, 0 insertions, 57 deletions
diff --git a/c/src/libnetworking/include/Makefile.am b/c/src/libnetworking/include/Makefile.am
deleted file mode 100644
index 888ef5599d..0000000000
--- a/c/src/libnetworking/include/Makefile.am
+++ /dev/null
@@ -1,57 +0,0 @@
-##
-## $Id$
-##
-##
-## FIXME: This Makefile.am is pretty ugly and deserves to be reworked :(
-##
-
-AUTOMAKE_OPTIONS = foreign 1.4
-
-H_FILES = ../bpfilter.h ../loop.h ../netdb.h ../opt_ipfw.h ../opt_mrouting.h \
- ../opt_tcpdebug.h ../poll.h ../resolv.h ../syslog.h ../memory.h
-
-# We only make the install point for the networking header files if needed.
-
-$(INSTALLDIRS):
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/bpfilter.h: ../bpfilter.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/loop.h: ../loop.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/netdb.h: ../netdb.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/opt_ipfw.h: ../opt_ipfw.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/opt_mrouting.h: ../opt_mrouting.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/opt_tcpdebug.h: ../opt_tcpdebug.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/poll.h: ../poll.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/resolv.h: ../resolv.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/syslog.h: ../syslog.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/memory.h: ../memory.h
- $(INSTALL_DATA) $< $@
-
-PREINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/bpfilter.h \
- $(PROJECT_INCLUDE)/loop.h $(PROJECT_INCLUDE)/netdb.h \
- $(PROJECT_INCLUDE)/opt_ipfw.h $(PROJECT_INCLUDE)/opt_mrouting.h \
- $(PROJECT_INCLUDE)/opt_tcpdebug.h $(PROJECT_INCLUDE)/poll.h \
- $(PROJECT_INCLUDE)/resolv.h $(PROJECT_INCLUDE)/syslog.h \
- $(PROJECT_INCLUDE)/memory.h
-
-all-local: $(PREINSTALL_FILES)
-
-include $(top_srcdir)/../../../automake/local.am