summaryrefslogtreecommitdiffstats
path: root/c/src/libchip/network/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-09-07 23:09:47 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-09-07 23:09:47 +0000
commita2117cd64a9d25926564e43ea2806f7eacde7343 (patch)
tree2f088b9c41fbff16b2ca11adca1b5ef4d871c3c9 /c/src/libchip/network/Makefile.am
parent2002-09-07 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-a2117cd64a9d25926564e43ea2806f7eacde7343.tar.bz2
2002-09-07 Chris Johns <ccj@acm.org>
* network/Makefile.am, network/README.cs8900, network/cs8900.c, network/cs8900.h: Significant update which corrects the problem where the cs8900.c file was actually the BSP glue. Joel did some hacking so this file will compile. Previously it required providing a target.h file to compile. * network/cs8900.c.bsp: New file.
Diffstat (limited to 'c/src/libchip/network/Makefile.am')
-rw-r--r--c/src/libchip/network/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/c/src/libchip/network/Makefile.am b/c/src/libchip/network/Makefile.am
index c916be1abd..48a052ed6a 100644
--- a/c/src/libchip/network/Makefile.am
+++ b/c/src/libchip/network/Makefile.am
@@ -8,8 +8,7 @@ include_libchipdir = $(includedir)/libchip
LIBNAME = libnetchip
LIB = $(ARCH)/$(LIBNAME).a
-# add cs8900.c to work with it and make it compile
-C_FILES = dec21140.c i82586.c sonic.c if_fxp.c
+C_FILES = cs8900.c dec21140.c i82586.c sonic.c if_fxp.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
include_libchip_HEADERS = cs8900.h i82586var.h if_fxpvar.h sonic.h
@@ -52,6 +51,6 @@ endif
.PRECIOUS: $(LIB)
EXTRA_DIST = README README.cs8900 README.dec21140 README.i82586 README.sonic \
- cs8900.c dec21140.c i82586.c if_fxp.c sonic.c
+ cs8900.c cs8900.c.bsp dec21140.c i82586.c if_fxp.c sonic.c
include $(top_srcdir)/../../../automake/local.am