summaryrefslogtreecommitdiffstats
path: root/c/src/libchip/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2007-12-14 04:54:57 +0000
committerChris Johns <chrisj@rtems.org>2007-12-14 04:54:57 +0000
commitf3bf21f2cf21ec70437cfbff12840148ce6a4034 (patch)
tree2e80ceb5ef6fae5193a1879621a414b428747410 /c/src/libchip/Makefile.am
parent2007-12-14 Chris Johns <chrisj@rtems.org> (diff)
downloadrtems-f3bf21f2cf21ec70437cfbff12840148ce6a4034.tar.bz2
2007-12-14 Chris Johns <chrisj@rtems.org>
* wrapup/Makefile.am: Add libflash.a to the libbsp library. * libchip/Makefile.am, libchip/preinstall.am: Add the flash chip support. * libchip/flash, libchip/flash/am29lv160.c, libchip/flash/am29lv160.h: New.
Diffstat (limited to 'c/src/libchip/Makefile.am')
-rw-r--r--c/src/libchip/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/c/src/libchip/Makefile.am b/c/src/libchip/Makefile.am
index 5cfca33da7..243c87d865 100644
--- a/c/src/libchip/Makefile.am
+++ b/c/src/libchip/Makefile.am
@@ -13,6 +13,15 @@ EXTRA_DIST =
noinst_LIBRARIES =
noinst_PROGRAMS =
+# flash
+if LIBCHIP
+include_libchip_HEADERS += flash/am29lv160.h
+
+noinst_LIBRARIES += libflash.a
+libflash_a_SOURCES = flash/am29lv160.c
+libflash_a_CPPFLAGS = $(AM_CPPFLAGS)
+endif
+
# ide
if LIBCHIP
include_libchip_HEADERS += ide/ata.h ide/ide_ctrl_cfg.h ide/ide_ctrl.h \