summaryrefslogtreecommitdiffstats
path: root/c/src/libchip/Makefile.am
diff options
context:
space:
mode:
authorTill Straumann <strauman@slac.stanford.edu>2005-11-03 02:52:41 +0000
committerTill Straumann <strauman@slac.stanford.edu>2005-11-03 02:52:41 +0000
commit78111c37c6174de035a546ca661f0f68bb68c4cd (patch)
tree4021f8669cde59979f675ec45a6dc940c13420a9 /c/src/libchip/Makefile.am
parent2005-11-02 straumanatslacdotstanford.edu (diff)
downloadrtems-78111c37c6174de035a546ca661f0f68bb68c4cd.tar.bz2
2005-11-02 straumanatslacdotstanford.edu
* libchip/i2c/i2c-2b-eeprom.c, libchip/i2c/i2c-2b-eeprom.h, libchip/i2c/i2c-ds1621.c, libchip/i2c/i2c-ds1621.h: New files. * libchip/Makefile.am, libchip/preinstall.am, wrapup/Makefile.am: added a simple API/library for i2c devices and drivers for i2c 2-byte eeproms and a ds1621 temperature sensor; API is documented in libi2c.h
Diffstat (limited to 'c/src/libchip/Makefile.am')
-rw-r--r--c/src/libchip/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/c/src/libchip/Makefile.am b/c/src/libchip/Makefile.am
index c4994535aa..90284212b8 100644
--- a/c/src/libchip/Makefile.am
+++ b/c/src/libchip/Makefile.am
@@ -62,6 +62,15 @@ endif
EXTRA_DIST += rtc/README.ds1643 rtc/README.icm7170 rtc/README.m48t08 \
rtc/README.m48t18 rtc/STATUS
+# i2c
+if LIBCHIP
+include_libchip_HEADERS += i2c/i2c-ds1621.h i2c/i2c-2b-eeprom.h
+
+noinst_LIBRARIES += libi2cio.a
+libi2cio_a_CPPFLAGS = $(AM_CPPFLAGS)
+libi2cio_a_SOURCES = i2c/i2c-ds1621.c i2c/i2c-2b-eeprom.c
+endif
+
# serial
if LIBCHIP
include_libchip_HEADERS += serial/mc68681.h serial/ns16550.h serial/z85c30.h \