summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sparc/Makefile.am
diff options
context:
space:
mode:
authorDaniel Hellstrom <daniel@gaisler.com>2012-02-08 15:57:03 +0100
committerGedare Bloom <gedare@rtems.org>2012-03-21 12:35:47 -0400
commit80d01b3cf8e4bb2998f1e8e99ed5b5d64ac8d23e (patch)
tree547fd0c47b52041da88d89c0d099659f8e1aa693 /c/src/lib/libcpu/sparc/Makefile.am
parentPR2041: sparc64: vector number not included in CPU_Interrupt_frame (diff)
downloadrtems-80d01b3cf8e4bb2998f1e8e99ed5b5d64ac8d23e.tar.bz2
SPARC: added libcpu lowlevel access and byteorder routines/definitions
The low level routines can be used in different occasions, it will be required when accessing PCI. Note the difference between byteorder.h (inlined functions) and access.S where the functions will be declared in the library archive librtemscpu.a. Function names starting with _ are in library and can be referenced by function pointers. Signed-off-by: Daniel Hellstrom <daniel@gaisler.com>
Diffstat (limited to 'c/src/lib/libcpu/sparc/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sparc/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/sparc/Makefile.am b/c/src/lib/libcpu/sparc/Makefile.am
index 7bebd9417e..711d6b1fa8 100644
--- a/c/src/lib/libcpu/sparc/Makefile.am
+++ b/c/src/lib/libcpu/sparc/Makefile.am
@@ -10,6 +10,8 @@ noinst_PROGRAMS =
include_libcpudir = $(includedir)/libcpu
include_libcpu_HEADERS = ../shared/include/cache.h
+include_libcpu_HEADERS += include/libcpu/byteorder.h
+include_libcpu_HEADERS += include/libcpu/access.h
noinst_PROGRAMS += cache.rel
cache_rel_SOURCES = cache/cache.c cache/cache_.h \
@@ -31,5 +33,10 @@ reg_win_rel_SOURCES = reg_win/window.S
reg_win_rel_CPPFLAGS = $(AM_CPPFLAGS)
reg_win_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+noinst_PROGRAMS += access.rel
+access_rel_SOURCES = access/access.S access/access_le.c
+access_rel_CPPFLAGS = $(AM_CPPFLAGS)
+access_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
include $(srcdir)/preinstall.am
include $(top_srcdir)/../../../automake/local.am