summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7750/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-12 13:19:08 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-12 13:19:08 +0000
commitba7107616869bff7dc80627eab666fceb5ff4fb5 (patch)
treeb5088da2155c328c23266af163798c7dfb19d1bb /c/src/lib/libcpu/sh/sh7750/include/Makefile.am
parent2001-10-11 Mike Siers <mikes@poliac.com> (diff)
downloadrtems-ba7107616869bff7dc80627eab666fceb5ff4fb5.tar.bz2
2001-10-11 Alexandra Kossovsky <sasha@oktet.ru>
* clock/Makefile.am, clock/ckinit.c, clock/.cvsignore, Makefile.am, include/Makefile.am, include/iosh7750.h, include/ipl.h, include/ispsh7750.h, include/sh4_regs.h, include/sh4uart.h, include/sh7750_regs.h, include/.cvsignore, sci/Makefile.am, sci/console.c, sci/sh4uart.c, sci/.cvsignore, score/Makefile.am, score/cpu_asm.c, score/ispsh7750.c, score/.cvsignore, timer/Makefile.am, timer/timer.c, timer/.cvsignore, configure.ac, .cvsignore, ChangeLog: New files. Reviewed and updated to latest automake and autoconf standards by Ralf Corsepius <corsepiu@faw.uni-ulm.de>.
Diffstat (limited to 'c/src/lib/libcpu/sh/sh7750/include/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/sh7750/include/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/sh/sh7750/include/Makefile.am b/c/src/lib/libcpu/sh/sh7750/include/Makefile.am
new file mode 100644
index 0000000000..02015de005
--- /dev/null
+++ b/c/src/lib/libcpu/sh/sh7750/include/Makefile.am
@@ -0,0 +1,38 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
+# file name conflicts
+include_shdir = $(includedir)/sh
+include_rtems_scoredir = $(includedir)/rtems/score
+
+include_sh_HEADERS = sh4uart.h
+include_rtems_score_HEADERS = ispsh7750.h iosh7750.h
+
+$(PROJECT_INCLUDE)/sh:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/sh/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/rtems/score/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES = $(PROJECT_INCLUDE)/sh \
+ $(include_sh_HEADERS:%=$(PROJECT_INCLUDE)/sh/%) \
+ $(include_rtems_score_HEADERS:%=$(PROJECT_INCLUDE)/rtems/score/%)
+
+all-local: $(TMPINSTALL_FILES)
+
+# FIXME: What are these files here?
+# They should either be installed or removed
+EXTRA_DIST = \
+ipl.h \
+sh4_regs.h \
+sh4uart.h \
+sh7750_regs.h
+
+include $(top_srcdir)/../../../../../../automake/local.am