summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7032/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-21 16:20:38 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-21 16:20:38 +0000
commit400c55255d516a27fd25de899826286458f559dc (patch)
treef6c262848a647ba5004d0297999500b81161532e /c/src/lib/libcpu/sh/sh7032/include/Makefile.am
parentPatch rtems-rc-19991203-10.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-400c55255d516a27fd25de899826286458f559dc.tar.bz2
Removing Makefile.in and adding Makefile.am. These were missed in conversion
to automake by Ralf Corsepius <corsepiu@faw.uni-ulm.de>.
Diffstat (limited to 'c/src/lib/libcpu/sh/sh7032/include/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/sh7032/include/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/sh/sh7032/include/Makefile.am b/c/src/lib/libcpu/sh/sh7032/include/Makefile.am
new file mode 100644
index 0000000000..feb0333fda
--- /dev/null
+++ b/c/src/lib/libcpu/sh/sh7032/include/Makefile.am
@@ -0,0 +1,24 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = null.h sci.h sh7_pfc.h sh7_sci.h
+noinst_HEADERS = $(H_FILES)
+
+# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
+# file name conflicts
+
+TMPINSTALL_FILES = $(PROJECT_INCLUDE)/sh \
+ $(H_FILES:%=$(PROJECT_INCLUDE)/sh/%)
+
+$(PROJECT_INCLUDE)/sh:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/sh/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../automake/local.am