summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-05-11 07:38:57 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-05-11 07:38:57 +0000
commit9fc8ed19353ab8aed4ee998e335d0e571605050c (patch)
tree1d4d939039b898915d227674bc202dceafbc4013 /c/src/lib/libcpu/sh/Makefile.am
parentRemove sh7032/Makefile. (diff)
downloadrtems-9fc8ed19353ab8aed4ee998e335d0e571605050c.tar.bz2
Merge-in sh7032/Makefile.am.
Diffstat (limited to 'c/src/lib/libcpu/sh/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/Makefile.am48
1 files changed, 47 insertions, 1 deletions
diff --git a/c/src/lib/libcpu/sh/Makefile.am b/c/src/lib/libcpu/sh/Makefile.am
index 4ed659a5c4..537e6ed3d6 100644
--- a/c/src/lib/libcpu/sh/Makefile.am
+++ b/c/src/lib/libcpu/sh/Makefile.am
@@ -4,7 +4,53 @@
ACLOCAL_AMFLAGS = -I ../../../aclocal
-SUBDIRS = sh7032 sh7045 sh7750
+include $(top_srcdir)/../../../automake/compile.am
+
+CLEANFILES =
+DISTCLEANFILES =
+noinst_PROGRAMS =
+
+SUBDIRS = sh7045 sh7750
+
+if sh7032
+# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
+# file name conflicts
+include_shdir = $(includedir)/sh
+include_rtems_scoredir = $(includedir)/rtems/score
+
+include_sh_HEADERS = sh7032/include/sci.h sh7032/include/sh7_pfc.h sh7032/include/sh7_sci.h
+include_rtems_score_HEADERS = sh7032/include/ispsh7032.h sh7032/include/iosh7032.h
+
+# clock
+noinst_PROGRAMS += sh7032/clock.rel
+sh7032_clock_rel_SOURCES = sh7032/clock/ckinit.c
+sh7032_clock_rel_CPPFLAGS = $(AM_CPPFLAGS)
+sh7032_clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+# delay
+noinst_PROGRAMS += sh7032/delay.rel
+sh7032_delay_rel_SOURCES = sh7032/delay/delay.c
+sh7032_delay_rel_CPPFLAGS = $(AM_CPPFLAGS)
+sh7032_delay_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+# sci
+noinst_PROGRAMS += sh7032/sci.rel
+sh7032_sci_rel_SOURCES = sh7032/sci/sci.c
+sh7032_sci_rel_CPPFLAGS = $(AM_CPPFLAGS)
+sh7032_sci_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+# score
+noinst_PROGRAMS += sh7032/score.rel
+sh7032_score_rel_SOURCES = sh7032/score/cpu_asm.c sh7032/score/ispsh7032.c
+sh7032_score_rel_CPPFLAGS = $(AM_CPPFLAGS)
+sh7032_score_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+## timer
+noinst_PROGRAMS += sh7032/timer.rel
+sh7032_timer_rel_SOURCES = sh7032/timer/timer.c
+sh7032_timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
+sh7032_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+endif
include $(top_srcdir)/../../../automake/subdirs.am
include $(top_srcdir)/../../../automake/local.am