summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/shared/include/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 11:51:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 11:51:05 +0000
commita9c795b965d9b39760c8be825aca4d5290af4563 (patch)
tree69c32899a123f12f41d9f855e3252c079e0e2ebd /c/src/lib/libcpu/powerpc/shared/include/Makefile.am
parent2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-a9c795b965d9b39760c8be825aca4d5290af4563.tar.bz2
2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc505/Makefile.am: Reformat. * mpc505/ictrl/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc505/timer/Makefile.am: Reformat. * mpc505/vectors/Makefile.am: Reformat. * mpc6xx/Makefile.am: Reformat. * mpc6xx/clock/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc6xx/exceptions/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc6xx/mmu/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc6xx/timer/Makefile.am: Reformat. * mpc6xx/wrapup/Makefile.am: Reformat. * mpc8260/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8260/clock/Makefile.am: Reformat. * mpc8260/console-generic/Makefile.am: Reformat. * mpc8260/cpm/Makefile.am: Reformat. * mpc8260/exceptions/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8260/mmu/Makefile.am: Reformat. * mpc8260/timer/Makefile.am: Reformat. * mpc8xx/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8xx/clock/Makefile.am: Reformat. * mpc8xx/console-generic/Makefile.am: Reformat. * mpc8xx/cpm/Makefile.am: Reformat. * mpc8xx/exceptions/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8xx/mmu/Makefile.am: Reformat. * mpc8xx/timer/Makefile.am: Reformat. * ppc403/Makefile.am: Reformat. * ppc403/clock/Makefile.am: Reformat. * ppc403/console/Makefile.am: Reformat. * ppc403/ictrl/Makefile.am: Reformat. Use dirstamp for preinstallation. * ppc403/timer/Makefile.am: Reformat. * ppc403/tty_drv/Makefile.am: Reformat. Use dirstamp for preinstallation. * ppc403/vectors/Makefile.am: Reformat. * shared/Makefile.am: Reformat. * shared/include/Makefile.am: Reformat. Use dirstamp for preinstallation. * shared/src/Makefile.am: Reformat. Use dirstamp for preinstallation. * wrapup/Makefile.am: Reformat.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/shared/include/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/shared/include/Makefile.am45
1 files changed, 35 insertions, 10 deletions
diff --git a/c/src/lib/libcpu/powerpc/shared/include/Makefile.am b/c/src/lib/libcpu/powerpc/shared/include/Makefile.am
index f06b756d2b..edcfc8150f 100644
--- a/c/src/lib/libcpu/powerpc/shared/include/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/shared/include/Makefile.am
@@ -2,7 +2,6 @@
## $Id$
##
-
C_FILES = cpuIdent.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
@@ -25,19 +24,45 @@ LIB = $(ARCH)/libcpuspec.a
$(LIB): $(OBJS)
$(make-library)
-$(PROJECT_INCLUDE)/libcpu:
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/libcpu/%.h: %.h
- $(INSTALL_DATA) $< $@
-
-PREINSTALL_FILES = $(PROJECT_INCLUDE)/libcpu \
- $(include_libcpu_HEADERS:%=$(PROJECT_INCLUDE)/libcpu/%)
-
all-local: $(ARCH) $(PREINSTALL_FILES) $(OBJS) $(LIB)
.PRECIOUS: $(LIB)
EXTRA_DIST = cpuIdent.c
+PREINSTALL_FILES =
+
+$(PROJECT_INCLUDE)/libcpu/$(dirstamp):
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/libcpu
+ @: > $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+
+$(PROJECT_INCLUDE)/libcpu/spr.h: spr.h $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/libcpu/spr.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/spr.h
+
+$(PROJECT_INCLUDE)/libcpu/io.h: io.h $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/libcpu/io.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/io.h
+
+$(PROJECT_INCLUDE)/libcpu/mmu.h: mmu.h $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/libcpu/mmu.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/mmu.h
+
+$(PROJECT_INCLUDE)/libcpu/page.h: page.h $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/libcpu/page.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/page.h
+
+$(PROJECT_INCLUDE)/libcpu/byteorder.h: byteorder.h $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/libcpu/byteorder.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/byteorder.h
+
+$(PROJECT_INCLUDE)/libcpu/pgtable.h: pgtable.h $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/libcpu/pgtable.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/pgtable.h
+
+$(PROJECT_INCLUDE)/libcpu/cpuIdent.h: cpuIdent.h $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/libcpu/cpuIdent.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/cpuIdent.h
+
include $(top_srcdir)/../../../automake/local.am