summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/shared/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-03-05 22:48:47 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-03-05 22:48:47 +0000
commit98f3cfa1a614dfbf8ab261b8b1a85043f0086764 (patch)
tree95a24fc48fad57285655a84c2f35dc7a1ee3ea47 /c/src/lib/libcpu/powerpc/shared/include/Makefile.am
parent2001-03-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-98f3cfa1a614dfbf8ab261b8b1a85043f0086764.tar.bz2
2001-02-27 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* mpc505/ictrl/Makefile.am, mpc6xx/clock/Makefile.am, mpc6xx/exceptions/Makefile.am, mpc6xx/mmu/Makefile.am, mpc8xx/include/Makefile.am, new_exception_processing/Makefile.am, old_exception_processing/Makefile.am, pc403/ictrl/Makefile.am, shared/include/Makefile.am, shared/src/Makefile.am: Apply *_HEADERS instead of *H_FILES. * shared/src/.cvsignore: Add cache.h.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/shared/include/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/shared/include/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/c/src/lib/libcpu/powerpc/shared/include/Makefile.am b/c/src/lib/libcpu/powerpc/shared/include/Makefile.am
index 3fc822d555..5b7e936557 100644
--- a/c/src/lib/libcpu/powerpc/shared/include/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/shared/include/Makefile.am
@@ -7,7 +7,9 @@ AUTOMAKE_OPTIONS = foreign 1.4
C_FILES = cpuIdent.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-H_FILES = cpu.h spr.h io.h mmu.h page.h byteorder.h pgtable.h
+include_libcpudir = $(includedir)/libcpu
+
+include_libcpu_HEADERS = cpu.h spr.h io.h mmu.h page.h byteorder.h pgtable.h
OBJS = $(C_O_FILES)
@@ -31,7 +33,7 @@ $(PROJECT_INCLUDE)/libcpu/%.h: %.h
$(INSTALL_DATA) $< $@
PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu \
- $(H_FILES:%=$(PROJECT_INCLUDE)/libcpu/%)
+ $(include_libcpu_HEADERS:%=$(PROJECT_INCLUDE)/libcpu/%)
all-local: $(ARCH) $(PREINSTALL_FILES) $(OBJS) $(LIB)