summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/ppc403/tty_drv/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-11-09 00:04:57 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-11-09 00:04:57 +0000
commite9ae97fbc6221ffb11b1ce14f6fc320dc602b686 (patch)
treed3143d5a2ee19ac375731e462a59cca3339182fc /c/src/lib/libcpu/powerpc/ppc403/tty_drv/Makefile.am
parent2001-11-08 Dennis Ehlin (ECS) <Dennis.Ehlin@ecs.ericsson.se> (diff)
downloadrtems-e9ae97fbc6221ffb11b1ce14f6fc320dc602b686.tar.bz2
2001-11-08 Dennis Ehlin (ECS) <Dennis.Ehlin@ecs.ericsson.se>
This modification is part of the submitted modifications necessary to support the IBM PPC405 family. This submission was reviewed by Thomas Doerfler <Thomas.Doerfler@imd-systems.de> who ensured it did not negatively impact the ppc403 BSPs. The submission and tracking process was captured as PR50. * ppc403/console/console405.c ppc403/tty_drv/.cvsignore, ppc403/tty_drv/Makefile.am, ppc403/tty_drv/tty_drv.c, ppc403/tty_drv/tty_drv.h: New files. * Makefile.am, README, configure.ac, old_exception_processing/cpu.c, old_exception_processing/cpu.h, ppc403/Makefile.am, ppc403/clock/clock.c, ppc403/console/Makefile.am, ppc403/console/console.c, ppc403/ictrl/ictrl.c, ppc403/ictrl/ictrl.h, ppc403/timer/timer.c: Modified.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/ppc403/tty_drv/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/ppc403/tty_drv/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/powerpc/ppc403/tty_drv/Makefile.am b/c/src/lib/libcpu/powerpc/ppc403/tty_drv/Makefile.am
new file mode 100644
index 0000000000..f445fec6d8
--- /dev/null
+++ b/c/src/lib/libcpu/powerpc/ppc403/tty_drv/Makefile.am
@@ -0,0 +1,32 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = $(ARCH)/tty_drv.rel
+
+include_HEADERS = tty_drv.h
+
+C_FILES = tty_drv.c
+
+tty_drv_rel_OBJECTS = $(C_FILES:%.c=$(ARCH)/%.o)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(tty_drv_rel_OBJECTS)
+ $(make-rel)
+
+all-local: $(ARCH) $(tty_drv_rel_OBJECTS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = tty_drv.c tty_drv.h
+
+include $(top_srcdir)/../../../../../automake/local.am