summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/mpc8260/cpm/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-22 13:42:45 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-22 13:42:45 +0000
commit1ec501c567ddc0cd377d6a14766d2306e12ccefc (patch)
treed1aa683bd72fd9a10bd8757153c0093f14f130df /c/src/lib/libcpu/powerpc/mpc8260/cpm/Makefile.am
parent2001-10-22 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-1ec501c567ddc0cd377d6a14766d2306e12ccefc.tar.bz2
2001-10-22 Andy Dachs <a.dachs@sstl.co.uk>
* Added mpc8260 directory. * Modified Makefile.am and configure.in to build the contents * mpc8260/Makefile.am, mpc8260/README, mpc8260/clock/Makefile.am, mpc8260/clock/clock.c, mpc8260/console-generic/Makefile.am, mpc8260/console-generic/console-generic.c, mpc8260/cpm/.cvsignore, mpc8260/cpm/Makefile.am, mpc8260/cpm/brg.c, mpc8260/cpm/cp.c, mpc8260/cpm/dpram.c, mpc8260/exceptions/.cvsignore, mpc8260/exceptions/Makefile.am, mpc8260/exceptions/asm_utils.S, mpc8260/exceptions/raw_exception.c, mpc8260/exceptions/raw_exception.h, mpc8260/include/Makefile.am, mpc8260/include/console.h, mpc8260/include/cpm.h, mpc8260/include/mmu.h, mpc8260/include/mpc8260.h, mpc8260/mmu/Makefile.am, mpc8260/mmu/mmu.c, mpc8260/timer/Makefile.am, mpc8260/timer/timer.c: New files.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/mpc8260/cpm/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/mpc8260/cpm/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/powerpc/mpc8260/cpm/Makefile.am b/c/src/lib/libcpu/powerpc/mpc8260/cpm/Makefile.am
new file mode 100644
index 0000000000..55cd146dff
--- /dev/null
+++ b/c/src/lib/libcpu/powerpc/mpc8260/cpm/Makefile.am
@@ -0,0 +1,29 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = ${ARCH}/cp.rel
+
+## C sources
+C_FILES = cp.c dpram.c brg.c
+
+cpm_rel_OBJECTS = $(C_FILES:%.c=${ARCH}/%.o)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(cpm_rel_OBJECTS)
+ $(make-rel)
+
+all-local: ${ARCH} $(PGM)
+
+EXTRA_DIST = $(C_FILES)
+
+include $(top_srcdir)/../../../../../automake/local.am