summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/mpc8260/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 11:51:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 11:51:05 +0000
commita9c795b965d9b39760c8be825aca4d5290af4563 (patch)
tree69c32899a123f12f41d9f855e3252c079e0e2ebd /c/src/lib/libcpu/powerpc/mpc8260/Makefile.am
parent2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-a9c795b965d9b39760c8be825aca4d5290af4563.tar.bz2
2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc505/Makefile.am: Reformat. * mpc505/ictrl/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc505/timer/Makefile.am: Reformat. * mpc505/vectors/Makefile.am: Reformat. * mpc6xx/Makefile.am: Reformat. * mpc6xx/clock/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc6xx/exceptions/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc6xx/mmu/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc6xx/timer/Makefile.am: Reformat. * mpc6xx/wrapup/Makefile.am: Reformat. * mpc8260/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8260/clock/Makefile.am: Reformat. * mpc8260/console-generic/Makefile.am: Reformat. * mpc8260/cpm/Makefile.am: Reformat. * mpc8260/exceptions/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8260/mmu/Makefile.am: Reformat. * mpc8260/timer/Makefile.am: Reformat. * mpc8xx/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8xx/clock/Makefile.am: Reformat. * mpc8xx/console-generic/Makefile.am: Reformat. * mpc8xx/cpm/Makefile.am: Reformat. * mpc8xx/exceptions/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8xx/mmu/Makefile.am: Reformat. * mpc8xx/timer/Makefile.am: Reformat. * ppc403/Makefile.am: Reformat. * ppc403/clock/Makefile.am: Reformat. * ppc403/console/Makefile.am: Reformat. * ppc403/ictrl/Makefile.am: Reformat. Use dirstamp for preinstallation. * ppc403/timer/Makefile.am: Reformat. * ppc403/tty_drv/Makefile.am: Reformat. Use dirstamp for preinstallation. * ppc403/vectors/Makefile.am: Reformat. * shared/Makefile.am: Reformat. * shared/include/Makefile.am: Reformat. Use dirstamp for preinstallation. * shared/src/Makefile.am: Reformat. Use dirstamp for preinstallation. * wrapup/Makefile.am: Reformat.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/mpc8260/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/mpc8260/Makefile.am35
1 files changed, 25 insertions, 10 deletions
diff --git a/c/src/lib/libcpu/powerpc/mpc8260/Makefile.am b/c/src/lib/libcpu/powerpc/mpc8260/Makefile.am
index b3988e579a..73f465c52e 100644
--- a/c/src/lib/libcpu/powerpc/mpc8260/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/mpc8260/Makefile.am
@@ -9,20 +9,35 @@ include_mpc8260dir = $(includedir)/mpc8260
include_HEADERS = include/mpc8260.h
include_mpc8260_HEADERS = include/console.h include/mmu.h include/cpm.h
-PREINSTALL_FILES = $(PROJECT_INCLUDE)/mpc8260 \
- $(include_HEADERS:include/%=$(PROJECT_INCLUDE)/%) \
- $(include_mpc8260_HEADERS:include/%=$(PROJECT_INCLUDE)/mpc8260/%)
+all-local: $(PREINSTALL_FILES)
-$(PROJECT_INCLUDE)/mpc8260:
- $(mkinstalldirs) $@
+PREINSTALL_FILES =
-$(PROJECT_INCLUDE)/%.h: include/%.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/$(dirstamp):
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)
+ @: > $(PROJECT_INCLUDE)/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/$(dirstamp)
-$(PROJECT_INCLUDE)/mpc8260/%.h: include/%.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/mpc8260/$(dirstamp):
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/mpc8260
+ @: > $(PROJECT_INCLUDE)/mpc8260/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/mpc8260/$(dirstamp)
-all-local: $(PREINSTALL_FILES)
+$(PROJECT_INCLUDE)/mpc8260.h: include/mpc8260.h $(PROJECT_INCLUDE)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/mpc8260.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/mpc8260.h
+
+$(PROJECT_INCLUDE)/mpc8260/console.h: include/console.h $(PROJECT_INCLUDE)/mpc8260/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/mpc8260/console.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/mpc8260/console.h
+
+$(PROJECT_INCLUDE)/mpc8260/mmu.h: include/mmu.h $(PROJECT_INCLUDE)/mpc8260/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/mpc8260/mmu.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/mpc8260/mmu.h
+
+$(PROJECT_INCLUDE)/mpc8260/cpm.h: include/cpm.h $(PROJECT_INCLUDE)/mpc8260/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/mpc8260/cpm.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/mpc8260/cpm.h
include $(top_srcdir)/../../../automake/subdirs.am
include $(top_srcdir)/../../../automake/local.am