summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/mpc6xx/mmu/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 11:51:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 11:51:05 +0000
commita9c795b965d9b39760c8be825aca4d5290af4563 (patch)
tree69c32899a123f12f41d9f855e3252c079e0e2ebd /c/src/lib/libcpu/powerpc/mpc6xx/mmu/Makefile.am
parent2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-a9c795b965d9b39760c8be825aca4d5290af4563.tar.bz2
2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc505/Makefile.am: Reformat. * mpc505/ictrl/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc505/timer/Makefile.am: Reformat. * mpc505/vectors/Makefile.am: Reformat. * mpc6xx/Makefile.am: Reformat. * mpc6xx/clock/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc6xx/exceptions/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc6xx/mmu/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc6xx/timer/Makefile.am: Reformat. * mpc6xx/wrapup/Makefile.am: Reformat. * mpc8260/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8260/clock/Makefile.am: Reformat. * mpc8260/console-generic/Makefile.am: Reformat. * mpc8260/cpm/Makefile.am: Reformat. * mpc8260/exceptions/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8260/mmu/Makefile.am: Reformat. * mpc8260/timer/Makefile.am: Reformat. * mpc8xx/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8xx/clock/Makefile.am: Reformat. * mpc8xx/console-generic/Makefile.am: Reformat. * mpc8xx/cpm/Makefile.am: Reformat. * mpc8xx/exceptions/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8xx/mmu/Makefile.am: Reformat. * mpc8xx/timer/Makefile.am: Reformat. * ppc403/Makefile.am: Reformat. * ppc403/clock/Makefile.am: Reformat. * ppc403/console/Makefile.am: Reformat. * ppc403/ictrl/Makefile.am: Reformat. Use dirstamp for preinstallation. * ppc403/timer/Makefile.am: Reformat. * ppc403/tty_drv/Makefile.am: Reformat. Use dirstamp for preinstallation. * ppc403/vectors/Makefile.am: Reformat. * shared/Makefile.am: Reformat. * shared/include/Makefile.am: Reformat. Use dirstamp for preinstallation. * shared/src/Makefile.am: Reformat. Use dirstamp for preinstallation. * wrapup/Makefile.am: Reformat.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/mpc6xx/mmu/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/mpc6xx/mmu/Makefile.am27
1 files changed, 17 insertions, 10 deletions
diff --git a/c/src/lib/libcpu/powerpc/mpc6xx/mmu/Makefile.am b/c/src/lib/libcpu/powerpc/mpc6xx/mmu/Makefile.am
index 183fd88c90..20b2ff0c4c 100644
--- a/c/src/lib/libcpu/powerpc/mpc6xx/mmu/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/mpc6xx/mmu/Makefile.am
@@ -2,7 +2,6 @@
## $Id$
##
-
PGM = $(ARCH)/mmu.rel
C_FILES = bat.c pte121.c
@@ -13,16 +12,12 @@ include_libcpudir = $(includedir)/libcpu
include_libcpu_HEADERS = bat.h pte121.h
-mmu_rel_OBJECTS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT)) $(S_FILES:%.S=$(ARCH)/%.$(OBJEXT))
+mmu_rel_OBJECTS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT)) \
+ $(S_FILES:%.S=$(ARCH)/%.$(OBJEXT))
include $(top_srcdir)/../../../automake/compile.am
include $(top_srcdir)/../../../automake/lib.am
-$(PROJECT_INCLUDE)/libcpu:
- $(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/libcpu/%.h: %.h
- $(INSTALL_DATA) $< $@
-
#
# (OPTIONAL) Add local stuff here using +=
#
@@ -30,13 +25,25 @@ $(PROJECT_INCLUDE)/libcpu/%.h: %.h
$(PGM): $(mmu_rel_OBJECTS)
$(make-rel)
-PREINSTALL_FILES = $(PROJECT_INCLUDE)/libcpu \
- $(include_libcpu_HEADERS:%=$(PROJECT_INCLUDE)/libcpu/%)
-
all-local: $(ARCH) $(PREINSTALL_FILES) $(mmu_rel_OBJECTS) $(PGM)
.PRECIOUS: $(PGM)
EXTRA_DIST = bat.c bat.h mmuAsm.S pte121.c pte121.h
+PREINSTALL_FILES =
+
+$(PROJECT_INCLUDE)/libcpu/$(dirstamp):
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/libcpu
+ @: > $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+
+$(PROJECT_INCLUDE)/libcpu/bat.h: bat.h $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/libcpu/bat.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/bat.h
+
+$(PROJECT_INCLUDE)/libcpu/pte121.h: pte121.h $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/libcpu/pte121.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/pte121.h
+
include $(top_srcdir)/../../../automake/local.am