summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/Makefile.am
diff options
context:
space:
mode:
authorTill Straumann <strauman@slac.stanford.edu>2009-12-02 01:33:51 +0000
committerTill Straumann <strauman@slac.stanford.edu>2009-12-02 01:33:51 +0000
commitfbee4ffddeef1aec126795ca602491a5549c190a (patch)
tree44754b4d2932b25822abda8905991fb7f3019729 /c/src/lib/libcpu/powerpc/Makefile.am
parent2009-12-01 Till Straumann <strauman@slac.stanford.edu> (diff)
downloadrtems-fbee4ffddeef1aec126795ca602491a5549c190a.tar.bz2
2009-12-01 Till Straumann <strauman@slac.stanford.edu>
* Makefile.am, mpc6xx/altivec: new directory implementing support for AltiVec context saving/restoring.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/powerpc/Makefile.am b/c/src/lib/libcpu/powerpc/Makefile.am
index 5de0014166..e898bc7754 100644
--- a/c/src/lib/libcpu/powerpc/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/Makefile.am
@@ -241,7 +241,14 @@ noinst_PROGRAMS += mpc6xx/timer.rel
mpc6xx_timer_rel_SOURCES = mpc6xx/timer/timer.c
mpc6xx_timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
mpc6xx_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+# mpc6xx/altivec
+noinst_PROGRAMS += mpc6xx/altivec.rel
+mpc6xx_altivec_rel_SOURCES = mpc6xx/altivec/vec_sup.c mpc6xx/altivec/vec_sup_asm.S
+mpc6xx_altivec_rel_CPPFLAGS = $(AM_CPPFLAGS)
+mpc6xx_altivec_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
+EXTRA_DIST += mpc6xx/altivec/README
if e500
# mpc6xx/clock