summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/Makefile.am
diff options
context:
space:
mode:
authorTill Straumann <strauman@slac.stanford.edu>2007-12-12 00:48:54 +0000
committerTill Straumann <strauman@slac.stanford.edu>2007-12-12 00:48:54 +0000
commitaea55715cdf04aa7d50b59b25471a5a7dfdfbe16 (patch)
tree9fbe7567ac82c2c21137e2eac0f51490ca94a767 /c/src/lib/libcpu/powerpc/Makefile.am
parent2007-12-11 Till Straumann <strauman@slac.stanford.edu> (diff)
downloadrtems-aea55715cdf04aa7d50b59b25471a5a7dfdfbe16.tar.bz2
2007-12-11 Till Straumann <strauman@slac.stanford.edu>
* Makefile.am, new-exceptions/bspsupport/README: provide new irq_bspsupport.rel which was split out of exc_bspsupport.rel to provide finer-grained control over what BSPs want to use.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/c/src/lib/libcpu/powerpc/Makefile.am b/c/src/lib/libcpu/powerpc/Makefile.am
index 617ada8c14..cf3ab7c5a2 100644
--- a/c/src/lib/libcpu/powerpc/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/Makefile.am
@@ -47,10 +47,16 @@ noinst_PROGRAMS += new-exceptions/exc_bspsupport.rel
new_exceptions_exc_bspsupport_rel_SOURCES = \
new-exceptions/bspsupport/ppc_exc.S \
new-exceptions/bspsupport/ppc_exc_hdl.c \
- new-exceptions/bspsupport/irq.c \
- new-exceptions/bspsupport/vectors_init.c
+ new-exceptions/bspsupport/ppc_exc_test.c \
+ new-exceptions/bspsupport/vectors_init.c
new_exceptions_exc_bspsupport_rel_CPPFLAGS = $(AM_CPPFLAGS)
new_exceptions_exc_bspsupport_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_PROGRAMS += new-exceptions/irq_bspsupport.rel
+
+new_exceptions_irq_bspsupport_rel_SOURCES = new-exceptions/bspsupport/irq.c
+new_exceptions_irq_bspsupport_rel_CPPFLAGS = $(AM_CPPFLAGS)
+new_exceptions_irq_bspsupport_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
endif
EXTRA_DIST += new-exceptions/bspsupport/vectors.h