summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 11:51:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 11:51:05 +0000
commita9c795b965d9b39760c8be825aca4d5290af4563 (patch)
tree69c32899a123f12f41d9f855e3252c079e0e2ebd /c/src/lib/libcpu/powerpc/Makefile.am
parent2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-a9c795b965d9b39760c8be825aca4d5290af4563.tar.bz2
2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc505/Makefile.am: Reformat. * mpc505/ictrl/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc505/timer/Makefile.am: Reformat. * mpc505/vectors/Makefile.am: Reformat. * mpc6xx/Makefile.am: Reformat. * mpc6xx/clock/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc6xx/exceptions/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc6xx/mmu/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc6xx/timer/Makefile.am: Reformat. * mpc6xx/wrapup/Makefile.am: Reformat. * mpc8260/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8260/clock/Makefile.am: Reformat. * mpc8260/console-generic/Makefile.am: Reformat. * mpc8260/cpm/Makefile.am: Reformat. * mpc8260/exceptions/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8260/mmu/Makefile.am: Reformat. * mpc8260/timer/Makefile.am: Reformat. * mpc8xx/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8xx/clock/Makefile.am: Reformat. * mpc8xx/console-generic/Makefile.am: Reformat. * mpc8xx/cpm/Makefile.am: Reformat. * mpc8xx/exceptions/Makefile.am: Reformat. Use dirstamp for preinstallation. * mpc8xx/mmu/Makefile.am: Reformat. * mpc8xx/timer/Makefile.am: Reformat. * ppc403/Makefile.am: Reformat. * ppc403/clock/Makefile.am: Reformat. * ppc403/console/Makefile.am: Reformat. * ppc403/ictrl/Makefile.am: Reformat. Use dirstamp for preinstallation. * ppc403/timer/Makefile.am: Reformat. * ppc403/tty_drv/Makefile.am: Reformat. Use dirstamp for preinstallation. * ppc403/vectors/Makefile.am: Reformat. * shared/Makefile.am: Reformat. * shared/include/Makefile.am: Reformat. Use dirstamp for preinstallation. * shared/src/Makefile.am: Reformat. Use dirstamp for preinstallation. * wrapup/Makefile.am: Reformat.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/Makefile.am35
1 files changed, 17 insertions, 18 deletions
diff --git a/c/src/lib/libcpu/powerpc/Makefile.am b/c/src/lib/libcpu/powerpc/Makefile.am
index 27230369e1..781ed782ed 100644
--- a/c/src/lib/libcpu/powerpc/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/Makefile.am
@@ -4,26 +4,10 @@
ACLOCAL_AMFLAGS = -I ../../../aclocal
-nobase_include_HEADERS = rtems/powerpc/cache.h \
+include_rtems_powerpcdir = $(includedir)/rtems/powerpc
+include_rtems_powerpc_HEADERS = rtems/powerpc/cache.h \
rtems/powerpc/debugmod.h
-$(PROJECT_INCLUDE):
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/rtems:
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/rtems/powerpc:
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/%: %
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES = $(PROJECT_INCLUDE) \
- $(PROJECT_INCLUDE)/rtems \
- $(PROJECT_INCLUDE)/rtems/powerpc \
- $(nobase_include_HEADERS:%=$(PROJECT_INCLUDE)/%)
-
## Check configure.in for conditions to set the conditionals below
if shared
SHARED_LIB = shared
@@ -53,5 +37,20 @@ SUBDIRS = $(SHARED_LIB) $(CPU_SUBDIR) wrapup
all-local: $(TMPINSTALL_FILES)
+PREINSTALL_FILES =
+
+$(PROJECT_INCLUDE)/rtems/powerpc/$(dirstamp):
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/powerpc
+ @: > $(PROJECT_INCLUDE)/rtems/powerpc/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/powerpc/$(dirstamp)
+
+$(PROJECT_INCLUDE)/rtems/powerpc/cache.h: rtems/powerpc/cache.h $(PROJECT_INCLUDE)/rtems/powerpc/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/powerpc/cache.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/powerpc/cache.h
+
+$(PROJECT_INCLUDE)/rtems/powerpc/debugmod.h: rtems/powerpc/debugmod.h $(PROJECT_INCLUDE)/rtems/powerpc/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/powerpc/debugmod.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/powerpc/debugmod.h
+
include $(top_srcdir)/../../../automake/subdirs.am
include $(top_srcdir)/../../../automake/local.am