summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2011-08-31 15:50:30 +0000
committerSebastian Huber <sebastian.huber@embedded-brains.de>2011-08-31 15:50:30 +0000
commit97fa2f1b1ee2d670407da52b44f0d522bebe3fdc (patch)
treed48336a57d7b87541a99378825105d7662914dd6 /c/src/lib/libcpu/powerpc/Makefile.am
parent2011-08-31 Sebastian Huber <sebastian.huber@embedded-brains.de> (diff)
downloadrtems-97fa2f1b1ee2d670407da52b44f0d522bebe3fdc.tar.bz2
2011-08-31 Sebastian Huber <sebastian.huber@embedded-brains.de>
* mpc55xx/include/fsl-mpc551x.h, mpc55xx/include/fsl-mpc555x.h, mpc55xx/include/fsl-mpc556x.h, mpc55xx/include/fsl-mpc567x.h, mpc55xx/include/regs-edma.h, mpc55xx/include/regs-mmu.h: New files. * Makefile.am, M preinstall.am: Reflect changes above. * mpc55xx/dspi/dspi.c: Update due to API changes. * mpc55xx/include/edma.h, mpc55xx/edma/edma.c: Rework to support multiple eDMA modules. Removed complex error interrupt handling. * mpc55xx/include/esci.h, mpc55xx/esci/esci.c: Support interrupt mode and printk(). Use configure options. * mpc55xx/include/irq.h: More defines. API changes. * mpc55xx/include/mpc55xx.h: API changes. * mpc55xx/include/reg-defs.h: Added register defines. * mpc55xx/include/regs.h: Use new register header files. * mpc55xx/include/siu.h: Fixed includes. * mpc55xx/misc/fmpll.S, mpc55xx/misc/copy.S, mpc55xx/misc/flash.S: Changed sections. API changes. Support MPC5674F.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/Makefile.am26
1 files changed, 17 insertions, 9 deletions
diff --git a/c/src/lib/libcpu/powerpc/Makefile.am b/c/src/lib/libcpu/powerpc/Makefile.am
index 93881cf4af..579957b542 100644
--- a/c/src/lib/libcpu/powerpc/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/Makefile.am
@@ -411,15 +411,23 @@ if mpc55xx
# Includes
include_mpc55xxdir = $(includedir)/mpc55xx
-include_mpc55xx_HEADERS = mpc55xx/include/regs.h \
- mpc55xx/include/reg-defs.h \
- mpc55xx/include/dspi.h \
- mpc55xx/include/edma.h \
- mpc55xx/include/emios.h \
- mpc55xx/include/mpc55xx.h \
- mpc55xx/include/esci.h \
- mpc55xx/include/siu.h \
- mpc55xx/include/watchdog.h
+include_mpc55xx_HEADERS =
+include_mpc55xx_HEADERS += mpc55xx/include/regs.h
+include_mpc55xx_HEADERS += mpc55xx/include/reg-defs.h
+include_mpc55xx_HEADERS += mpc55xx/include/dspi.h
+include_mpc55xx_HEADERS += mpc55xx/include/edma.h
+include_mpc55xx_HEADERS += mpc55xx/include/emios.h
+include_mpc55xx_HEADERS += mpc55xx/include/mpc55xx.h
+include_mpc55xx_HEADERS += mpc55xx/include/esci.h
+include_mpc55xx_HEADERS += mpc55xx/include/siu.h
+include_mpc55xx_HEADERS += mpc55xx/include/irq.h
+include_mpc55xx_HEADERS += mpc55xx/include/watchdog.h
+include_mpc55xx_HEADERS += mpc55xx/include/fsl-mpc551x.h
+include_mpc55xx_HEADERS += mpc55xx/include/fsl-mpc555x.h
+include_mpc55xx_HEADERS += mpc55xx/include/fsl-mpc556x.h
+include_mpc55xx_HEADERS += mpc55xx/include/fsl-mpc567x.h
+include_mpc55xx_HEADERS += mpc55xx/include/regs-edma.h
+include_mpc55xx_HEADERS += mpc55xx/include/regs-mmu.h
include_bsp_HEADERS += mpc55xx/include/irq.h