summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/Makefile.am
diff options
context:
space:
mode:
authorTill Straumann <strauman@slac.stanford.edu>2007-12-06 00:21:07 +0000
committerTill Straumann <strauman@slac.stanford.edu>2007-12-06 00:21:07 +0000
commit694c00cb4e989364e7619918ab76255ebde407bf (patch)
tree87c06231f7d5a01e705e96969e11f82e6809439b /c/src/lib/libcpu/powerpc/Makefile.am
parent2007-12-05 Till Straumann <strauman@slac.stanford.edu> (diff)
downloadrtems-694c00cb4e989364e7619918ab76255ebde407bf.tar.bz2
2007-12-05 Till Straumann <strauman@slac.stanford.edu>
* Makefile.am, configure.ac, preinstall.am, new-exceptions/e500_raw_exc_init.c: Started adding support for e500 CPU. Most stuff is borrowed from mpc6xx.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/c/src/lib/libcpu/powerpc/Makefile.am b/c/src/lib/libcpu/powerpc/Makefile.am
index c5290d5d9a..7c1a94ef04 100644
--- a/c/src/lib/libcpu/powerpc/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/Makefile.am
@@ -29,7 +29,8 @@ old_exceptions_rtems_cpu_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
else
noinst_PROGRAMS = new-exceptions/rtems-cpu.rel
new_exceptions_rtems_cpu_rel_SOURCES = new-exceptions/cpu.c \
- new-exceptions/cpu_asm.S
+ new-exceptions/cpu_asm.S \
+ new-exceptions/e500_raw_exc_init.c
new_exceptions_rtems_cpu_rel_CPPFLAGS = $(AM_CPPFLAGS)
new_exceptions_rtems_cpu_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
@@ -238,6 +239,22 @@ mpc6xx_timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
mpc6xx_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
+if e500
+## mpc6xx/clock
+include_libcpu_HEADERS += mpc6xx/clock/c_clock.h
+
+noinst_PROGRAMS += e500/clock.rel
+e500_clock_rel_SOURCES = mpc6xx/clock/c_clock.c mpc6xx/clock/c_clock.h
+e500_clock_rel_CPPFLAGS = $(AM_CPPFLAGS)
+e500_clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+## mpc6xx/timer
+noinst_PROGRAMS += e500/timer.rel
+e500_timer_rel_SOURCES = mpc6xx/timer/timer.c
+e500_timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
+e500_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+endif
+
EXTRA_DIST += mpc8xx/README
if mpc8xx
include_mpc8xxdir = $(includedir)/mpc8xx