summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-20 13:33:28 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-20 13:33:28 +0000
commit623ffdb1555b66935ef4b0624ec7953134fd2f26 (patch)
tree5c77cc33ee675aceb9d6e5c00352c19964a6417c /c/src/lib/libcpu/powerpc/Makefile.am
parent2000-10-20 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-623ffdb1555b66935ef4b0624ec7953134fd2f26.tar.bz2
2000-10-20 Joel Sherrill <joel@OARcorp.com>
* configure.in, Makefile.am: Explicitly specify whether an RTEMS_CPU_MODEL is using old or new exception processing. This is important because when building multilib, you do not know the RTEMS_CPU_MODEL. So everything built in a multilib'ed RTEMS must be independent of the exception model and allow for late binding to the exception code.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/c/src/lib/libcpu/powerpc/Makefile.am b/c/src/lib/libcpu/powerpc/Makefile.am
index 17ebfd2b9a..115a02c80e 100644
--- a/c/src/lib/libcpu/powerpc/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/Makefile.am
@@ -10,9 +10,12 @@ if shared
SHARED_LIB = shared
endif
+## Use new or old exception processing based on the CPU
if new_exception_processing
EXCEPTION_SUBDIR = new_exception_processing
-else
+endif
+
+if old_exception_processing
EXCEPTION_SUBDIR = old_exception_processing
endif