summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/Makefile.am
diff options
context:
space:
mode:
authorThomas Doerfler <Thomas.Doerfler@embedded-brains.de>2010-03-25 20:26:51 +0000
committerThomas Doerfler <Thomas.Doerfler@embedded-brains.de>2010-03-25 20:26:51 +0000
commit1f4db180af76c320984dda1fc371c993bfadad35 (patch)
treec78e187ccdcb9cc1f8332ffebd39f3fd4b60b5ad /c/src/lib/libcpu/powerpc/Makefile.am
parentadd support for mpc551x based GW_LCFM system (diff)
downloadrtems-1f4db180af76c320984dda1fc371c993bfadad35.tar.bz2
fix timer support, some reworks
Diffstat (limited to 'c/src/lib/libcpu/powerpc/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/powerpc/Makefile.am b/c/src/lib/libcpu/powerpc/Makefile.am
index e898bc7754..51d0d5c631 100644
--- a/c/src/lib/libcpu/powerpc/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/Makefile.am
@@ -416,6 +416,7 @@ include_mpc55xx_HEADERS = mpc55xx/include/regs.h \
mpc55xx/include/emios.h \
mpc55xx/include/mpc55xx.h \
mpc55xx/include/esci.h \
+ mpc55xx/include/siu.h \
mpc55xx/include/watchdog.h
include_bsp_HEADERS += mpc55xx/include/irq.h
@@ -425,6 +426,12 @@ noinst_PROGRAMS += mpc55xx/irq.rel
mpc55xx_irq_rel_SOURCES = mpc55xx/irq/irq.c
mpc55xx_irq_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+# mpc6xx/timer
+noinst_PROGRAMS += mpc55xx/timer.rel
+mpc55xx_timer_rel_SOURCES = mpc6xx/timer/timer.c
+mpc55xx_timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
+mpc55xx_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
# FEC
noinst_PROGRAMS += mpc55xx/fec.rel
mpc55xx_fec_rel_SOURCES = mpc55xx/fec/fec.c
@@ -440,6 +447,11 @@ noinst_PROGRAMS += mpc55xx/emios.rel
mpc55xx_emios_rel_SOURCES = mpc55xx/emios/emios.c
mpc55xx_emios_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+# SIU
+noinst_PROGRAMS += mpc55xx/siu.rel
+mpc55xx_siu_rel_SOURCES = mpc55xx/siu/siu.c
+mpc55xx_siu_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
# eSCI
noinst_PROGRAMS += mpc55xx/esci.rel
mpc55xx_esci_rel_SOURCES = mpc55xx/esci/esci.c