summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/mips/tx39/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 11:33:47 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 11:33:47 +0000
commitc6c4418c6c9921f69d7abd0f1895b25d3edf9a5c (patch)
tree6713553075b609e2ec9c35ecddc13dd61f2d839d /c/src/lib/libcpu/mips/tx39/Makefile.am
parent2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-c6c4418c6c9921f69d7abd0f1895b25d3edf9a5c.tar.bz2
2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Reformat. * clock/Makefile.am: Reformat. * mongoosev/Makefile.am: Reformat. Use dirstamps for preinstallation. * tx39/Makefile.am: Ditto. * shared/cache/Makefile.am: Ditto. * mongoosev/duart/Makefile.am: Ditto. * mongoosev/vectorisrs/Makefile.am: Reformat. * r46xx/vectorisrs/Makefile.am: Reformat. * shared/Makefile.am: Reformat. * shared/interrupts/Makefile.am: Reformat. * timer/Makefile.am: Reformat. * tx39/vectorisrs/Makefile.am: Reformat.
Diffstat (limited to 'c/src/lib/libcpu/mips/tx39/Makefile.am')
-rw-r--r--c/src/lib/libcpu/mips/tx39/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/c/src/lib/libcpu/mips/tx39/Makefile.am b/c/src/lib/libcpu/mips/tx39/Makefile.am
index 7cc324119b..26715c7f48 100644
--- a/c/src/lib/libcpu/mips/tx39/Makefile.am
+++ b/c/src/lib/libcpu/mips/tx39/Makefile.am
@@ -13,12 +13,13 @@ all-local: $(PREINSTALL_FILES)
PREINSTALL_FILES =
-$(PROJECT_INCLUDE)/libcpu:
+$(PROJECT_INCLUDE)/libcpu/$(dirstamp):
@$(mkinstalldirs) $(PROJECT_INCLUDE)/libcpu
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu
+ @: > $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
-$(PROJECT_INCLUDE)/libcpu/tx3904.h: include/tx3904.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/libcpu/tx3904.h: include/tx3904.h $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/libcpu/tx3904.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/tx3904.h
include $(top_srcdir)/../../../automake/subdirs.am