summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/mips/tx39/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 06:50:10 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 06:50:10 +0000
commit63ae87612da91339a32ceecd218546a469d45b4a (patch)
tree9c8cfd43b9a367cbc4e5f8fe86071014afe64911 /c/src/lib/libcpu/mips/tx39/Makefile.am
parent2003-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-63ae87612da91339a32ceecd218546a469d45b4a.tar.bz2
2004-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* clock/Makefile.am, timer/Makefile.am: Remove. * r46xx/Makefile.am: Built timer.rel, clock.rel. Add PREINSTALL_DIRS. * Makefile.am: Remove timer, clock. * tx39/Makefile.am, mongoosev/Makefile.am, shared/Makefile.am: Add PREINSTALL_DIRS. * configure.ac: Reflect removing clock/Makefile.am, timer/Makefile.am. Add subdir-objects to AUTOMAKE_OPTIONS.
Diffstat (limited to 'c/src/lib/libcpu/mips/tx39/Makefile.am')
-rw-r--r--c/src/lib/libcpu/mips/tx39/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/c/src/lib/libcpu/mips/tx39/Makefile.am b/c/src/lib/libcpu/mips/tx39/Makefile.am
index 9211c676a7..e459497f4c 100644
--- a/c/src/lib/libcpu/mips/tx39/Makefile.am
+++ b/c/src/lib/libcpu/mips/tx39/Makefile.am
@@ -32,13 +32,14 @@ endif
all-local: $(PREINSTALL_FILES)
+PREINSTALL_DIRS =
PREINSTALL_FILES =
if tx39
$(PROJECT_INCLUDE)/libcpu/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/libcpu
@: > $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
$(PROJECT_INCLUDE)/libcpu/tx3904.h: include/tx3904.h $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/libcpu/tx3904.h
@@ -46,5 +47,6 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/tx3904.h
endif
CLEANFILES += $(PREINSTALL_FILES)
+DISTCLEANFILES = $(PREINSTALL_DIRS)
include $(top_srcdir)/../../../automake/local.am