summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/mips/tx39/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-10-23 13:55:49 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-10-23 13:55:49 +0000
commit1b4a37ad587423fc980472c6a6e67d9ceb25cd31 (patch)
tree443a561cbca2d5764238f62ffcb4519e0e6dcdd6 /c/src/lib/libcpu/mips/tx39/Makefile.am
parent2003-10-23 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-1b4a37ad587423fc980472c6a6e67d9ceb25cd31.tar.bz2
2003-10-23 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* mongoosev/Makefile.am: Rework preinstall rules. * mongoosev/duart/Makefile.am: Rework preinstall rules. * tx39/include/Makefile.am: Remove. * tx39/Makefile.am: Merge-in tx39/include/Makefile.am. * configure.ac: Remove tx39/include/Makefile.
Diffstat (limited to 'c/src/lib/libcpu/mips/tx39/Makefile.am')
-rw-r--r--c/src/lib/libcpu/mips/tx39/Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/c/src/lib/libcpu/mips/tx39/Makefile.am b/c/src/lib/libcpu/mips/tx39/Makefile.am
index 56f18eba68..7cc324119b 100644
--- a/c/src/lib/libcpu/mips/tx39/Makefile.am
+++ b/c/src/lib/libcpu/mips/tx39/Makefile.am
@@ -4,7 +4,22 @@
ACLOCAL_AMFLAGS = -I ../../../../../../aclocal
-SUBDIRS = include vectorisrs
+SUBDIRS = . vectorisrs
+
+include_libcpudir = $(includedir)/libcpu
+include_libcpu_HEADERS = include/tx3904.h
+
+all-local: $(PREINSTALL_FILES)
+
+PREINSTALL_FILES =
+
+$(PROJECT_INCLUDE)/libcpu:
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/libcpu
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu
+
+$(PROJECT_INCLUDE)/libcpu/tx3904.h: include/tx3904.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/tx3904.h
include $(top_srcdir)/../../../automake/subdirs.am
include $(top_srcdir)/../../../automake/local.am