summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 11:33:47 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 11:33:47 +0000
commitc6c4418c6c9921f69d7abd0f1895b25d3edf9a5c (patch)
tree6713553075b609e2ec9c35ecddc13dd61f2d839d /c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am
parent2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-c6c4418c6c9921f69d7abd0f1895b25d3edf9a5c.tar.bz2
2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Reformat. * clock/Makefile.am: Reformat. * mongoosev/Makefile.am: Reformat. Use dirstamps for preinstallation. * tx39/Makefile.am: Ditto. * shared/cache/Makefile.am: Ditto. * mongoosev/duart/Makefile.am: Ditto. * mongoosev/vectorisrs/Makefile.am: Reformat. * r46xx/vectorisrs/Makefile.am: Reformat. * shared/Makefile.am: Reformat. * shared/interrupts/Makefile.am: Reformat. * timer/Makefile.am: Reformat. * tx39/vectorisrs/Makefile.am: Reformat.
Diffstat (limited to 'c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am')
-rw-r--r--c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am b/c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am
index c3b199a1e3..69fe77a3dc 100644
--- a/c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am
+++ b/c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am
@@ -29,12 +29,13 @@ EXTRA_DIST = mg5uart.c README.mguart mg5uart.c mg5uart_reg.c
PREINSTALL_FILES =
-$(PROJECT_INCLUDE)/libchip:
+$(PROJECT_INCLUDE)/libchip/$(dirstamp):
@$(mkinstalldirs) $(PROJECT_INCLUDE)/libchip
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/libchip
+ @: > $(PROJECT_INCLUDE)/libchip/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libchip/$(dirstamp)
-$(PROJECT_INCLUDE)/libchip/mg5uart.h: mg5uart.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/libchip/mg5uart.h: mg5uart.h $(PROJECT_INCLUDE)/libchip/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/libchip/mg5uart.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/libchip/mg5uart.h
include $(top_srcdir)/../../../automake/local.am