summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-10-23 13:55:49 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-10-23 13:55:49 +0000
commit1b4a37ad587423fc980472c6a6e67d9ceb25cd31 (patch)
tree443a561cbca2d5764238f62ffcb4519e0e6dcdd6 /c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am
parent2003-10-23 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-1b4a37ad587423fc980472c6a6e67d9ceb25cd31.tar.bz2
2003-10-23 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* mongoosev/Makefile.am: Rework preinstall rules. * mongoosev/duart/Makefile.am: Rework preinstall rules. * tx39/include/Makefile.am: Remove. * tx39/Makefile.am: Merge-in tx39/include/Makefile.am. * configure.ac: Remove tx39/include/Makefile.
Diffstat (limited to 'c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am')
-rw-r--r--c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am25
1 files changed, 13 insertions, 12 deletions
diff --git a/c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am b/c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am
index 3accaa54d2..c3b199a1e3 100644
--- a/c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am
+++ b/c/src/lib/libcpu/mips/mongoosev/duart/Makefile.am
@@ -2,7 +2,6 @@
## $Id$
##
-
PGM = $(ARCH)/mg5uart.rel
C_FILES = mg5uart.c mg5uart_reg.c
@@ -12,11 +11,6 @@ mg5uart_rel_OBJECTS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
include $(top_srcdir)/../../../automake/compile.am
include $(top_srcdir)/../../../automake/lib.am
-$(PROJECT_INCLUDE)/libchip:
- @$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/libchip/%.h: %.h
- $(INSTALL_DATA) $< $@
-
#
# (OPTIONAL) Add local stuff here using +=
#
@@ -24,16 +18,23 @@ $(PROJECT_INCLUDE)/libchip/%.h: %.h
$(PGM): $(mg5uart_rel_OBJECTS)
$(make-rel)
-## include_libchip_HEADERS = mg5uart.h
-
-PREINSTALL_FILES = $(PROJECT_INCLUDE)/libchip \
- $(PROJECT_INCLUDE)/libchip/mg5uart.h
+include_libchipdir = $(includedir)/libchip
+include_libchip_HEADERS = mg5uart.h
-## $(include_libchip_HEADERS:%=$(PROJECT_INCLUDE)/libchip/%)
all-local: $(ARCH) $(PREINSTALL_FILES) $(mg5uart_rel_OBJECTS) $(PGM)
.PRECIOUS: $(PGM)
-EXTRA_DIST = mg5uart.c README.mguart mg5uart.c mg5uart.h mg5uart_reg.c
+EXTRA_DIST = mg5uart.c README.mguart mg5uart.c mg5uart_reg.c
+
+PREINSTALL_FILES =
+
+$(PROJECT_INCLUDE)/libchip:
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/libchip
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libchip
+
+$(PROJECT_INCLUDE)/libchip/mg5uart.h: mg5uart.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libchip/mg5uart.h
include $(top_srcdir)/../../../automake/local.am