summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/mips/mongoosev/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-11-02 14:33:39 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-11-02 14:33:39 +0000
commitff118d4bdc2a3370dd252bc07385bada53b87c4b (patch)
tree145e5daa289daf724efb918e4a3146652ce96ad8 /c/src/lib/libcpu/mips/mongoosev/Makefile.am
parent2002-11-02 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-ff118d4bdc2a3370dd252bc07385bada53b87c4b.tar.bz2
2002-11-02 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* mongoosev/Makefile.am: Merge-in mongoosev/include/Makefile.am. Install include/mongoose-v.h. * mongoosev/include/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libcpu/mips/mongoosev/Makefile.am')
-rw-r--r--c/src/lib/libcpu/mips/mongoosev/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/c/src/lib/libcpu/mips/mongoosev/Makefile.am b/c/src/lib/libcpu/mips/mongoosev/Makefile.am
index b34b2d28b3..911dc51ee8 100644
--- a/c/src/lib/libcpu/mips/mongoosev/Makefile.am
+++ b/c/src/lib/libcpu/mips/mongoosev/Makefile.am
@@ -4,7 +4,21 @@
ACLOCAL_AMFLAGS = -I ../../../../../../aclocal
-SUBDIRS = include duart vectorisrs
+SUBDIRS = duart vectorisrs
+
+include_mipsdir = $(includedir)/libcpu
+include_mips_HEADERS = include/mongoose-v.h
+
+$(PROJECT_INCLUDE)/libcpu:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/libcpu/%.h: include/%.h
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES = $(PROJECT_INCLUDE)/libcpu \
+ $(include_mips_HEADERS:include/%.h=$(PROJECT_INCLUDE)/libcpu/%.h)
+
+all-local: $(TMPINSTALL_FILES)
include $(top_srcdir)/../../../../../automake/subdirs.am
include $(top_srcdir)/../../../../../automake/local.am