summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/mips/mongoosev/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 06:50:10 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 06:50:10 +0000
commit63ae87612da91339a32ceecd218546a469d45b4a (patch)
tree9c8cfd43b9a367cbc4e5f8fe86071014afe64911 /c/src/lib/libcpu/mips/mongoosev/Makefile.am
parent2003-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-63ae87612da91339a32ceecd218546a469d45b4a.tar.bz2
2004-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* clock/Makefile.am, timer/Makefile.am: Remove. * r46xx/Makefile.am: Built timer.rel, clock.rel. Add PREINSTALL_DIRS. * Makefile.am: Remove timer, clock. * tx39/Makefile.am, mongoosev/Makefile.am, shared/Makefile.am: Add PREINSTALL_DIRS. * configure.ac: Reflect removing clock/Makefile.am, timer/Makefile.am. Add subdir-objects to AUTOMAKE_OPTIONS.
Diffstat (limited to 'c/src/lib/libcpu/mips/mongoosev/Makefile.am')
-rw-r--r--c/src/lib/libcpu/mips/mongoosev/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/c/src/lib/libcpu/mips/mongoosev/Makefile.am b/c/src/lib/libcpu/mips/mongoosev/Makefile.am
index 9c3fb721b5..900e5d8c25 100644
--- a/c/src/lib/libcpu/mips/mongoosev/Makefile.am
+++ b/c/src/lib/libcpu/mips/mongoosev/Makefile.am
@@ -55,13 +55,14 @@ endif
all-local: $(PREINSTALL_FILES)
+PREINSTALL_DIRS =
PREINSTALL_FILES =
if mongoosev
$(PROJECT_INCLUDE)/libcpu/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/libcpu
@: > $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
$(PROJECT_INCLUDE)/libcpu/mongoose-v.h: include/mongoose-v.h $(PROJECT_INCLUDE)/libcpu/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/libcpu/mongoose-v.h
@@ -70,7 +71,7 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/mongoose-v.h
$(PROJECT_INCLUDE)/libchip/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/libchip
@: > $(PROJECT_INCLUDE)/libchip/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/libchip/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/libchip/$(dirstamp)
$(PROJECT_INCLUDE)/libchip/mg5uart.h: duart/mg5uart.h $(PROJECT_INCLUDE)/libchip/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/libchip/mg5uart.h
@@ -78,5 +79,6 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/libchip/mg5uart.h
endif
CLEANFILES += $(PREINSTALL_FILES)
+DISTCLEANFILES = $(PREINSTALL_DIRS)
include $(top_srcdir)/../../../automake/local.am