summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/m68k/shared/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-01-02 12:32:04 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-01-02 12:32:04 +0000
commit67c9abf43ccd541cca57e7532253565ca1884606 (patch)
tree537af15fede2b4e337057386a39bb0905cd68873 /c/src/lib/libcpu/m68k/shared/Makefile.am
parent2005-01-02 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-67c9abf43ccd541cca57e7532253565ca1884606.tar.bz2
2005-01-02 Ralf Corsepius <ralf.corsepius@rtems.org>
* m68040/Makefile.am, mcf5206/Makefile.am, mcf5272/Makefile.am, shared/Makefile.am: Remove build-variant support.
Diffstat (limited to 'c/src/lib/libcpu/m68k/shared/Makefile.am')
-rw-r--r--c/src/lib/libcpu/m68k/shared/Makefile.am29
1 files changed, 4 insertions, 25 deletions
diff --git a/c/src/lib/libcpu/m68k/shared/Makefile.am b/c/src/lib/libcpu/m68k/shared/Makefile.am
index e41b7e2fb9..5cd156256f 100644
--- a/c/src/lib/libcpu/m68k/shared/Makefile.am
+++ b/c/src/lib/libcpu/m68k/shared/Makefile.am
@@ -2,10 +2,7 @@
## $Id$
##
-CLEANFILES =
-EXTRA_DIST =
-EXTRA_PROGRAMS =
-noinst_DATA =
+noinst_PROGRAMS =
include $(top_srcdir)/../../../automake/compile.am
@@ -15,22 +12,13 @@ include_libcpudir = $(includedir)/libcpu
## cache
include_libcpu_HEADERS = ../../shared/include/cache.h
-EXTRA_PROGRAMS += cache.rel
-CLEANFILES += cache.rel
+noinst_PROGRAMS += cache.rel
cache_rel_SOURCES = cache/cache.c cache/cache_.h \
../../shared/src/cache_aligned_malloc.c \
../../shared/src/cache_manager.c
cache_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V) -I$(srcdir)/cache
cache_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_PROGRAMS += cache_g.rel
-CLEANFILES += cache_g.rel
-cache_g_rel_SOURCES = $(cache_rel_SOURCES)
-cache_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V) -I$(srcdir)/cache
-cache_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += cache$(LIB_VARIANT).rel
-
## misc
# gcc doesn't recognize difference between the cpu32 and cpu32+ so we have to
@@ -41,19 +29,10 @@ if mcf5272
M68K_CPPFLAGS = -Dmcf5272
endif
-EXTRA_PROGRAMS += misc.rel
-CLEANFILES += misc.rel
+noinst_PROGRAMS += misc.rel
misc_rel_SOURCES = misc/memcpy.c misc/m68kidle.c
misc_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V) $(M68K_CPPFLAGS)
misc_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-EXTRA_PROGRAMS += misc_g.rel
-CLEANFILES += misc_g.rel
-misc_g_rel_SOURCES = $(misc_rel_SOURCES)
-misc_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V) $(M68K_CPPFLAGS)
-misc_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += misc$(LIB_VARIANT).rel
endif
## --
@@ -74,7 +53,7 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/cache.h
endif
-CLEANFILES += $(PREINSTALL_FILES)
+CLEANFILES = $(PREINSTALL_FILES)
DISTCLEANFILES = $(PREINSTALL_DIRS)
include $(top_srcdir)/../../../automake/local.am