summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/m68k/m68040/fpsp/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-20 02:20:27 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-20 02:20:27 +0000
commit180394472f3bf31f7b3eb2e6a90c34f6c3419142 (patch)
tree7aef1afe21ab39c2188b137be6d020da30f1ed18 /c/src/lib/libcpu/m68k/m68040/fpsp/Makefile.am
parent2004-01-20 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-180394472f3bf31f7b3eb2e6a90c34f6c3419142.tar.bz2
2004-01-20 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* m68040/Makefile.am: Merge-in m68040/fpsp/Makefile.am. Use automake-compilation rules. * m68040/fpsp/Makefile.am: Remove. * shared/Makefile.am: Use automake compilation rules. * Makefile.am: Reflect changes above. Remove CPU_SUBDIR. * configure.ac: Require automake >= 1.8.2. Add subdir-objects to AUTOMAKE_OPTIONS. Remove CHECK_CUSTOM_BSP. Reflect changes above.
Diffstat (limited to 'c/src/lib/libcpu/m68k/m68040/fpsp/Makefile.am')
-rw-r--r--c/src/lib/libcpu/m68k/m68040/fpsp/Makefile.am43
1 files changed, 0 insertions, 43 deletions
diff --git a/c/src/lib/libcpu/m68k/m68040/fpsp/Makefile.am b/c/src/lib/libcpu/m68k/m68040/fpsp/Makefile.am
deleted file mode 100644
index dd856d76a8..0000000000
--- a/c/src/lib/libcpu/m68k/m68040/fpsp/Makefile.am
+++ /dev/null
@@ -1,43 +0,0 @@
-##
-## $Id$
-##
-
-PGM = $(ARCH)/fpsp.rel
-
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
-
-C_FILES = rtems_fpsp.c
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-noinst_HEADERS = fpsp.defs
-
-S_FILES = bindec.S binstr.S bugfix.S decbin.S do_func.S gen_except.S \
- get_op.S kernel_ex.S res_func.S round.S rtems_skel.S sacos.S sasin.S \
- satan.S satanh.S scale.S scosh.S setox.S sgetem.S sint.S slog2.S slogn.S \
- smovecr.S srem_mod.S ssin.S ssinh.S stan.S stanh.S sto_res.S stwotox.S \
- tbldo.S util.S x_bsun.S x_fline.S x_operr.S x_ovfl.S x_snan.S x_store.S \
- x_unfl.S x_unimp.S x_unsupp.S
-OBJS += $(S_FILES:%.S=$(ARCH)/%.$(OBJEXT))
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-$(PGM): $(OBJS)
- $(make-rel)
-
-if m68040
-all-local: $(OBJS) $(PGM)
-endif
-
-.PRECIOUS: $(PGM)
-
-EXTRA_DIST = README bindec.S binstr.S bugfix.S decbin.S do_func.S fpsp.defs \
- gen_except.S get_op.S kernel_ex.S res_func.S round.S rtems_fpsp.c \
- rtems_skel.S sacos.S sasin.S satan.S satanh.S scale.S scosh.S setox.S \
- sgetem.S sint.S slog2.S slogn.S smovecr.S srem_mod.S ssin.S ssinh.S \
- stan.S stanh.S sto_res.S stwotox.S tbldo.S util.S x_bsun.S x_fline.S \
- x_operr.S x_ovfl.S x_snan.S x_store.S x_unfl.S x_unimp.S x_unsupp.S
-
-include $(top_srcdir)/../../../automake/local.am