summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/arm/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-11-21 15:45:32 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-11-21 15:45:32 +0000
commit4eee8434e151fd542232fcee346d8c7e13fe92c3 (patch)
tree6972c41d85c8a5a57530c79fd06288b21e4104ff /c/src/lib/libcpu/arm/Makefile.am
parentnumerous changes (diff)
downloadrtems-4eee8434e151fd542232fcee346d8c7e13fe92c3.tar.bz2
2009-11-21 Fernando Nicodemos <fgnicodemos@terra.com.br>
* Makefile.am, preinstall.am, at91rm9200/include/at91rm9200.h: Add initial support for USART on at91rm9200. * at91rm9200/include/at91rm9200_usart.h, at91rm9200/usart/usart.c: New files.
Diffstat (limited to 'c/src/lib/libcpu/arm/Makefile.am')
-rw-r--r--c/src/lib/libcpu/arm/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/c/src/lib/libcpu/arm/Makefile.am b/c/src/lib/libcpu/arm/Makefile.am
index 317942fd22..b7b5ec0b47 100644
--- a/c/src/lib/libcpu/arm/Makefile.am
+++ b/c/src/lib/libcpu/arm/Makefile.am
@@ -26,7 +26,7 @@ endif
if pxa255
include_HEADERS = pxa255/include/pxa255.h pxa255/include/ffuart.h
-##pxa255/clock
+## pxa255/clock
noinst_PROGRAMS += pxa255/clock.rel
pxa255_clock_rel_SOURCES = pxa255/clock/clock.c
pxa255_clock_rel_CPPFLAGS = $(AM_CPPFLAGS)
@@ -63,7 +63,8 @@ endif
if at91rm9200
include_HEADERS = at91rm9200/include/at91rm9200.h at91rm9200/include/at91rm9200_dbgu.h \
at91rm9200/include/at91rm9200_emac.h at91rm9200/include/at91rm9200_gpio.h \
- at91rm9200/include/at91rm9200_mem.h at91rm9200/include/at91rm9200_pmc.h at91rm9200/include/bits.h
+ at91rm9200/include/at91rm9200_mem.h at91rm9200/include/at91rm9200_pmc.h \
+ at91rm9200/include/bits.h at91rm9200/include/at91rm9200_usart.h
## at91rm9200/clock
noinst_PROGRAMS += at91rm9200/clock.rel
@@ -77,6 +78,12 @@ at91rm9200_dbgu_rel_SOURCES = at91rm9200/dbgu/dbgu.c
at91rm9200_dbgu_rel_CPPFLAGS = $(AM_CPPFLAGS)
at91rm9200_dbgu_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+## at91rm9200/usart
+noinst_PROGRAMS += at91rm9200/usart.rel
+at91rm9200_usart_rel_SOURCES = at91rm9200/usart/usart.c
+at91rm9200_usart_rel_CPPFLAGS = $(AM_CPPFLAGS)
+at91rm9200_usart_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
## at91rm9200/timer
noinst_PROGRAMS += at91rm9200/timer.rel
at91rm9200_timer_rel_SOURCES = at91rm9200/timer/timer.c