summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-25 14:58:13 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-25 16:08:16 +0100
commit7e5c9b895e52c76376386e54a0008c3a9e4a1698 (patch)
treebb8f7db25258fc1438c58a60aa950d782d0d77ab /c/src/lib/libcpu/Makefile.am
parentsptest/spcache01: New test cases (diff)
downloadrtems-7e5c9b895e52c76376386e54a0008c3a9e4a1698.tar.bz2
rtems: Move rtems_cache_aligned_malloc()
Make sure also the size is cache aligned since otherwise we may have some overlap with the next allocation block. A cache invalidate on this area would be fatal.
Diffstat (limited to 'c/src/lib/libcpu/Makefile.am')
-rw-r--r--c/src/lib/libcpu/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/c/src/lib/libcpu/Makefile.am b/c/src/lib/libcpu/Makefile.am
index 7d3a43e4f6..630f5256a0 100644
--- a/c/src/lib/libcpu/Makefile.am
+++ b/c/src/lib/libcpu/Makefile.am
@@ -2,7 +2,6 @@ include_libcpudir = $(includedir)/libcpu
EXTRA_DIST =
EXTRA_DIST += shared/include/cache.h
-EXTRA_DIST += shared/src/cache_aligned_malloc.c
EXTRA_DIST += shared/src/cache_manager.c
SUBDIRS = @libcpu_cpu_subdir@